Aktionsabfrage <Jet-Definition>

Aktionsabfrage

Eine Abfrage, die Daten kopiert oder ändert. Aktionsabfragen umfassen Anfüge-, Lösch-, Tabellenerstellungs- und Aktualisierungsabfragen. Lösch- und Aktualisierungsabfragen ändern bereits vorhandene Daten; Anfüge- und Tabellenerstellungsabfragen kopieren bestehende Daten. Bei SQL werden diese als DML-Abfragen bezeichnet und bestehen aus den Schlüsselwörtern DELETE, INSERT und UPDATE. Microsoft® Jet unterstützt das Schlüsselwort SELECT INTO, das auch als DDL-Abfrage angesehen wird. Im Gegensatz dazu geben Auswahlabfragen Datensätze zurück. Eine SQL-Pass-Through-Abfrage kann ebenfalls eine Aktionsabfrage sein.


ADO (Active Data Objects) <Jet-Definition>

ADO (Active Data Objects)

Eine Programmierschnittstelle zum Zugreifen auf und Bearbeiten von Datenbankobjekten.


Aggregatfunktion <Jet-Definition>

Aggregatfunktion

Eine Funktion wie Sum, Count, Avg und Max, die zur Berechnung von Ergebniswerten verwendet wird. Beim Formulieren von Ausdrücken und beim Programmieren können Sie SQL-Aggregatfunktionen (einschließlich der vier genannten) und Domänen-Aggregatfunktionen verwenden, um bestimmte statistische Berechnungen durchzuführen.


Alias <Jet-Definition>

Alias

Visual Basic: Ein alternativer Name in Microsoft® Visual Basic®, den Sie einer externen Prozedur geben, um Konflikte mit einem Visual Basic-Schlüsselwort, einer öffentlichen Variablen, einer Konstanten oder einem Namen, der nach den Visual Basic-Namenskonventionen unzulässig ist, zu vermeiden.

SQL (Structured Query Language): Ein alternativer Name, den Sie einem Feld oder einem Ausdruck in einer SELECT-Anweisung (mit dem optionalen AS-Abschnitt) geben. ANSI verweist dabei auf den Alias als Korrelationsnamen.


ANSI-Zeichensatz <Jet-Definition>

ANSI-Zeichensatz

Ein 8-Bit-Zeichensatz (ANSI = American National Standards Institute), der von Microsoft® Windows® verwendet wird. Der Zeichensatz kann zur Darstellung von bis zu 256 Zeichen (0 bis 255) mit Hilfe der Tastatur verwendet werden. Der ASCII-Zeichensatz ist eine Untermenge des ANSI-Zeichensatzes.


ANSI SQL 92-Modus <Jet-Definition>

ANSI SQL 92-Modus

Dieser Modus ermöglicht eine erweiterte SQL-Syntax, die kompatibler zu SQL-92 und Microsoft® SQL Server™ ist. Dieser Modus steht nur zur Verfügung, wenn Sie über Microsoft OLE DB Provider for Jet gehen. Er kann nicht gesetzt werden, wenn Sie über DAO gehen. Neue Funktionen stehen primär mit DDL zur Verfügung. Die Unterstützung der ANSI-Platzhalterzeichen, das Prozentzeichen (%) und der Unterstrich (_), sind ebenfalls Bestandteil des ANSI SQL 92-Modus.


Anfügeabfrage <Jet-Definition>

Anfügeabfrage

Eine Aktionsabfrage, die neue Datensätze am Ende einer bestehenden Tabelle oder Abfrage hinzufügt. Anfügeabfragen geben keine Datensätze (Zeilen) zurück. Die SQL-Syntax würde das Schlüsselwort INSERT enthalten.


Argument <Jet-Definition>

Argument

Eine Konstante, eine Variable oder ein Ausdruck, der/die zusätzliche Informationen zu einer Aktion, Prozedur oder Methode enthält. Argumente werden mit Operanden in Ausdrücken verwendet, um die für einige Aktionen benötigten Zusatzinformationen bereitzustellen.


Datenfeld <Jet-Definition>

Datenfeld

Eine Variable mit einer endlichen Anzahl von Elementen, die einen gemeinsamen Namen und Datentyp haben. Jedes Element eines Datenfelds wird durch eine eindeutige Indexnummer bezeichnet. Änderungen an einem Element eines Datenfelds haben keine Auswirkungen auf die anderen Elemente.


ASCII-Zeichensatz <Jet-Definition>

ASCII-Zeichensatz

Ein weit verbreiteter 7-Bit Zeichensatz (ASCII = American Standard Code for Information Interchange), der zur Darstellung der Buchstaben und Symbole auf einer US-Standardtastatur verwendet wird. Der ASCII-Zeichensatz entspricht den ersten 128 Zeichen (0 bis 127) des ANSI-Zeichensatzes.


Sternchen <Jet-Definition>

Sternchen

Ein Zeichen (*), das als Platzhalterzeichen in SQL LIKE-Ausdrücken stellvertretend für eine beliebige Folge von Zeichen verwendet wird. Der Ausdruck LIKE "stadt*" gibt z. B. Datensätze zurück, die die Zeichenfolge "stadt" gefolgt von null oder mehr Zeichen enthalten.

Wenn Sie eine Abfrage erstellen oder eine SQL-Anweisung eingeben, verwenden Sie das Sternchen, um alle Felder einzuschließen, die momentan in der zugrundeliegenden Tabelle oder Abfrage vorhanden sind. SELECT * FROM Tabelle1 gibt z. B. alle Felder (Spalten) der Tabelle "Tabelle1" zurück.

Beim Ausgeben einer Abfrage über Microsoft® OLE DB Provider for Jet, wird das Sternchen nicht mehr als Platzhalterzeichen verwendet. Vielmehr wird das Prozentzeichen (%) als ANSI-Platzhalterzeichen verwendet. Auf gespeicherte Abfragen wirkt sich dies nicht aus, jedoch müssen neue über Microsoft OLE DB Provider for Jet erstellte Abfragen (Ansichten) die ANSI-Platzhalterzeichen, Prozentzeichen (%) und Unterstrich (_), verwenden, um ein ähnliches Verhalten zu erzielen, wie das bei Sternchen (*) und Fragezeichen (?). Microsoft OLE DB Provider for Jet übersetzt das Sternchen und das Fragezeichen als Literalzeichen, so dass die zurückgegebene Ergebnismenge zur Benutzeroberfläche bzw. DAO von Microsoft Access unterschiedlich sein wird.


Asynchrone Abfrage <Jet-Definition>

Asynchrone Abfrage

Ein Abfragetyp, in der SQL-Abfragen sofort zurückgeben werden, auch wenn das Ergebnis noch nicht feststeht. Dadurch kann die Anwendung mit anderen Vorgängen fortfahren, während die Abfrage noch beendet wird.


Autowert-Feld <Jet-Definition>

Autowert-Feld

Ein Felddatentyp, der für jeden Datensatz automatisch eine eindeutige Zahl speichert, wenn dieser einer Tabelle hinzugefügt wird. Ein Autowert-Feld verwendet stets den Datentyp Long. Mit einem Autowert-Feld erzeugte Zahlen können nicht geändert werden, es sei denn, der Tabelle wurde mit Hilfe von Grant- oder Revoke-Anweisungen in der SQL DDL-Syntax eine spezielle Berechtigung erteilt. Das Autowert-Feld wird auch als Zähler- oder Identitäts-Datentyp bezeichnet. Bei der Verwendung von SQL DDL unterstützt dieser Datentyp nun auch sich ändernde Ausgangs- und Inkrementwerte. Dies ist im Vergleich zu früheren Versionen unterschiedlich, da der Ausgangswert 1 und der Inkrementwert stets 1 waren.

Siehe auch

Identitätsattribut

Ausgangswert

Inkrementwert


Basistabelle <Jet-Definition>

Basistabelle

Eine Tabelle in einer Microsoft® Jet-Datenbank. Eine Tabelle definiert die Struktur einer relationalen Datenbank und ist ein Objekt, das Daten in Datensätzen und Feldern speichert. Sie verändern die Struktur einer Basistabelle mit den DAO-Objekten oder SQL-Anweisungen zur Datendefinition (DDL), und Sie können Daten in einer Basistabelle mit Recordset-Objekten oder Aktionsabfragen verändern.


Big Integer (Datentyp) <Jet-Definition>

Big Integer (Datentyp)

Ein Datentyp, der einen genauen numerischen Wert mit Vorzeichen mit der Präzision 19 (mit Vorzeichen) oder 20 (ohne Vorzeichen), Dezimalstelle 0 (mit Vorzeichen: -263 ≤ n ≤ 263-1; ohne Vorzeichen: 0 ≤ n ≤ 264-1) speichert.


Binary (Datentyp) <Jet-Definition>

Binary (Datentyp)

Ein Datentyp, der binäre Daten einer festgelegten Länge speichert. Die maximale Länge beträgt 255 Bytes.


Lesezeichen <Jet-Definition>

Lesezeichen

Eine Eigenschaft des Recordset-Objekts, das eine Binär-Zeichenfolge enthält, die den aktuellen Datensatz kennzeichnet. Wenn Sie den Wert vom Typ Bookmark einer Variablen zuweisen und dann zu einem anderen Datensatz wechseln, können Sie den vorhergehenden Datensatz wieder zum aktuellen Datensatz machen, indem Sie die Bookmark-Eigenschaft der Zeichenfolgenvariablen zuweisen.


Boolescher Ausdruck <Jet-Definition>

Boolescher Ausdruck

Ein Ausdruck, der als Ergebniswert entweder True oder False liefert.


Boolean (Datentyp) <Jet-Definition>

Boolean (Datentyp)

Der Wert True/False bzw. Ja/Nein. Werte vom Typ Boolean werden in der Regel in Bitfeldern in einer Microsoft® Jet-Datenbank gespeichert, aber manche Datenbanken unterstützen diesen Datentyp nicht direkt.


Byte (Datentyp) <Jet-Definition>

Byte (Datentyp)

Ein grundlegender Datentyp, der verwendet wird, um kleine positive Ganzzahlen im Bereich von 0 bis 255 aufzunehmen.


Kartesisches Produkt <Jet-Definition>

Kartesisches Produkt

Das Ergebnis der Verknüpfung zweier in Beziehung stehender Tabellen, bei dem alle möglichen geordneten Kombinationen aus den Zeilen der ersten Tabelle und den Zeilen der zweiten Tabelle erzeugt werden.

Im allgemeinen entsteht ein kartesisches Produkt, wenn eine SQL SELECT-Anweisung ausgeführt wird, die mindestens zwei Tabellen in der FROM-Klausel (in anderen Anwendungen wird eine Klausel auch als Abschnitt bezeichnet) angibt und keine WHERE- oder JOIN-Klausel umfasst, der anzeigt, wie die Tabellen miteinander verknüpft werden sollen.


Weitergabe (Kaskade) <Jet-Definition>

Weitergabe (Kaskade)

Das Auslösen einer Operation durch eine andere. Wenn z. B. für eine Beziehung zwischen mindestens zwei Tabellen die Aktualisierungsweitergabe (Kaskadierende Aktualisierung) aktiviert ist, löst eine Aktualisierung des Primärschlüssels in der Primärtabelle automatisch Änderungen in der Fremdtabelle aus.

Nun ebenfalls von SQL DDL aus festlegbar.


Löschweitergabe (Kaskadierendes Löschen) <Jet-Definition>

Löschweitergabe (Kaskadierendes Löschen)

Bei Beziehungen, die die referenzielle Integrität zwischen Tabellen durchsetzen, können Sie die Löschweitergabe (Kaskadierendes Löschen) verwenden; hierbei wird ein Datensatz aus der Primärtabelle gelöscht und anschließend werden automatisch alle dazu in Beziehung stehenden Datensätze der zugehörigen Fremdtabelle oder -tabellen gelöscht.

Wenn Sie beispielsweise eine Beziehung zwischen einer Kunden- (Primär-) und einer Bestellungstabelle (Fremdtabelle) einrichten, wobei die Löschweitergabe (Kaskadierendes Löschen) aktiviert ist, werden beim Löschen eines Datensatzes in der Kundentabelle alle diesem Kunden zugeordneten Bestellungen ebenfalls in der Fremdtabelle "Bestellungen" gelöscht.

Nun ebenfalls von SQL DDL aus festlegbar.


Aktualisierungsweitergabe (Kaskadierende Aktualisierung) <Jet-Definition>

Aktualisierungsweitergabe (Kaskadierende Aktualisierung)

Bei Beziehungen, die die referenzielle Integrität zwischen Tabellen durchsetzen, können Sie die Aktualisierungsweitergabe (Kaskadierende Aktualisierung) verwenden; hierbei wird der Primärschlüssel eines Datensatzes aus der Primärtabelle geändert und anschließend werden automatisch die Fremdschlüssel aller dazu in Beziehung stehenden Datensätze der zugehörigen Fremdtabelle oder -tabellen aktualisiert.

Wenn Sie beispielsweise eine Beziehung zwischen einer Kunden- (Primär-) und einer Bestellungstabelle (Fremdtabelle) einrichten, wobei die Aktualisierungsweitergabe (Kaskadierende Aktualisierung) aktiviert ist, werden beim Ändern eines Primärschlüssels in der Kundentabelle alle diesem Kunden zugeordneten Bestellungen ebenfalls in der Fremdtabelle "Bestellungen" geändert.

Nun ebenfalls von SQL DDL aus festlegbar.


NULL-Weitergabe <Jet-Definition>

NULL-Weitergabe

Bei Beziehungen, die die referenzielle Integrität zwischen Tabellen durchsetzen, können Sie die NULL-Weitergabe verwenden; hierbei aktualisiert eine in der Primärtabelle gelöschte Zeile automatisch den Fremdschlüssel in allen zugehörigen Datensätzen der entsprechenden Fremdtabelle bzw. -tabellen mit einem NULL-Wert.

Nun ebenfalls von SQL DDL aus festlegbar.

Wenn Sie beispielsweise eine Beziehung zwischen einer Kunden- (Primär-) und einer Bestellungstabelle (Fremdtabelle) einrichten, wobei die NULL-Weitergabe aktiviert ist, werden beim Löschen eines Primärschlüssels in der Kundentabelle alle diesem Kunden zugeordneten Bestellungen ebenfalls in der Fremdtabelle "Bestellungen" zu NULL geändert.


Groß-/Kleinschreibung <Jet-Definition>

Groß-/Kleinschreibung

Die Möglichkeit, zwischen Groß- und Kleinbuchstaben zu unterscheiden. Bei einer Suche, die zwischen Groß- und Kleinschreibung unterscheidet, wird nur der Text gefunden, bei dem die Groß- und Kleinbuchstaben genau mit denen des Suchtexts übereinstimmen. Bei einer solchen Suche werden beispielsweise "NullZeichenfolge" und "Nullzeichenfolge" unterschiedlich behandelt. Operationen der Microsoft® Jet-Datenbank unterscheiden nicht zwischen Groß- und Kleinschreibung. Bei einigen anderen Datenbankmanagement-Systemen kann jedoch zwischen Groß- und Kleinschreibung unterschieden werden.


Char (Datentyp) <Jet-Definition>

Char (Datentyp)

Ein Datentyp, der eine Zeichenfolge einer festgelegten Länge speichert. Die Länge wird durch die Size-Eigenschaft festgelegt.


CHECK-Beschränkung <Jet-Definition>

CHECK-Beschränkung

Ein ANSI SQL-92-Konzept, mit dem Geschäftsregeln erstellt werden können, die eine vollständige Tabelle bzw. mehrere andere Tabellen umfassen. Ein Beispiel für eine solche Einschränkung wäre die Erstellung einer Tabelle mit Kunden und Bestellungen. Die Tabelle "Bestellungen" könnte dann eine CHECK-Einschränkung aufweisen, die dafür sorgt, dass Bestellungen eines Kunden über einen bestimmten Kreditrahmen, der für den Kunden in der Kundentabelle festgelegt wurde, nicht hinausgehen.


Klasse <Jet-Definition>

Klasse

Die formale Definition eines Objekts. Eine Klasse dient als Vorlage für die Instanz eines Objekts, das zur Laufzeit erstellt wird. Die Klasse definiert die Eigenschaften des Objekts sowie die Methoden zur Steuerung des Objektverhaltens.


Client Cursor-Bibliothek <Jet-Definition>

Client-Cursor-Bibliothek

Eine Bibliothek, die Client-Cursor-Unterstützung für ODBCDirect-Datenbankanwendungen bietet. Die Bibliothek unterstützt alle vier Typen von Cursor (Schlüsselgruppe, Statisch, Dynamisch und Vorwärts) und bietet eine Reihe von weiteren Funktionen, wie z. B. das Trennen von Verbindungen und Ausführen von teilweisen Stapelaktualisierungen.


Gruppierter Index <Jet-Definition>

Gruppierter Index

Die physikalischen Sortierreihenfolge der Zeilen ist dieselbe wie die indizierte Reihenfolge der Zeilen.


Auflistung <Jet-Definition>

Auflistung

Ein Objekt, das eine Gruppe von miteinander verwandten Objekten enthält. Die Position eines Objekts in der Auflistung kann sich mit jeder Veränderung in der Auflistung ändern. Deshalb steht die Position eines bestimmten Objekts in der Auflistung nicht fest.


Kollision <Jet-Definition>

Kollision

Ein Konflikt, der während einer Stapelaktualisierung auftritt.

Eine Kollision tritt auf, wenn ein Client Daten von einem Server liest und versucht, die Daten im Rahmen einer Stapelaktualisierung zu verändern, sofern während dieser Aktualisierung ein anderer Client die Originaldaten auf dem Server verändert. Anschließend versucht der erste Client, die Daten zu verändern, ohne Informationen darüber, welche Daten sich wirklich auf dem Server befinden.


Spalte <Jet-Definition>

Spalte

Die visuelle Darstellung eines Feldes in einem Raster. Eine Spalte definiert den Datentyp, die Größe und andere Attribute eines Feldes in einer Zeile mit Daten (einem Datensatz). Alle Spalten zusammen definieren eine Zeile (Datensatz) in der Datenbank. Eine einzelne Spalte enthält Daten, die in der ganzen Tabelle einen ähnlichen Typ und Zweck haben, d. h., die Definition einer Spalte bleibt für alle Zeilen gleich.


Verfolgung (Tracking) auf Spaltenebene <Jet-Definition>

Verfolgung (Tracking) auf Spaltenebene

Bei der Verfolgung auf Spaltenebene handelt es sich um einen Mechanismus, bei dem die einzelnen Spalten einer Zeile zur individuellen Konfliktbestimmung und -auflösung verwendet werden. Ändern mehrere Replikate dieselbe Zeile, die einzelnen Replikate jedoch jeweils eine andere Spalte ändern, tritt kein Konflikt auf und werden sämtliche Änderungen zusammengeführt.


Übernehmen (Commit) <Jet-Definition>

Übernehmen (Commit)

Endgültiges Übernehmen einer noch nicht abgeschlossen Transaktion. Wenn Sie Transaktionen verwenden und eine DAO-, ADO- oder SQL-Transaktion beginnen, werden die Änderungen, die im Laufe der Transaktionen vorgenommen wurden, erst dann endgültig in der Datenbank gespeichert, wenn Sie die Transaktion explizit übernehmen.


Verbundabfrage <Jet-Definition>

Verbundabfrage

Eine Abfrage, die aus mindestens einer Aktionsabfrage (eine Abfrage, die Daten kopiert oder ändert) und mindestens einer Auswahlabfrage (eine Abfrage, die ein Recordset-Objekt zurückgibt, ohne Daten zu verändern) besteht. In DAO wird eine Verbundabfrage erstellt, indem zwei oder mehr SQL-Anweisungen (getrennt durch Semikolons) in die SQL-Eigenschaft des QueryDef-Objekts eingeschlossen werden.


Verbindungszeichenfolge <Jet-Definition>

Verbindungszeichenfolge

Eine Zeichenfolge, mit der die Quelle der Daten für eine externe Datenbank definiert wird. Die Verbindungszeichenfolge wird in der Regel der Connect-Eigenschaft eines QueryDef-, TableDef-, Connection- oder Database-Objekts zugewiesen oder als Argument für die OpenDatabase-Methode verwendet.


Konsistent <Jet-Definition>

Konsistent

Der Zustand eines Recordset-Objekts für mehrere Tabellen, in dem Sie nur Aktualisierungen durchführen können, bei denen die Sicht auf die Daten konsistent bleibt. Beispielsweise ist es in einem Recordset-Objekt, das eine Verknüpfung von mindestens zwei Tabellen (eine 1:n-Beziehung) darstellt, bei einer konsistenten Abfrage nicht möglich, den Schlüssel auf der n-Seite auf einen Wert zu setzen, der in der Tabelle auf der 1-Seite nicht vorhanden ist.


Konstante <Jet-Definition>

Konstante

Ein Element mit einem Namen, das während der gesamten Programmausführung einen konstanten Wert behält, im Gegensatz zu einer Variablen, deren Wert sich während der Ausführung ändern kann. Jede Host-Anwendung kann eine Reihe von eigenen Konstanten definieren. Weitere Konstanten können vom Benutzer mit der Const-Anweisung definiert werden. Konstanten können überall in Ihrem Code anstelle der tatsächlichen Werte verwendet werden. Konstanten können Zeichenfolgenkonstanten, numerische Werte, andere Konstanten oder eine Kombination daraus unter Verwendung arithmetischer oder logischer Operatoren (mit Ausnahme der Is-Anweisung und der Exponentialfunktion) sein. Beispiel:

Const strdb = "c:\Programme\Microsoft Office\Access\Beispiele\Nordwind.mdb"


Beschränkung <Jet-Definition>

Beschränkung

Eine Begrenzung der verfügbaren Werte, die ein Benutzer in ein Feld eingeben kann. Die ANSI SQL DDL CHECK-Einschränkung wurde Microsoft® Jet, Version 4.x, hinzugefügt, wenn Sie über Microsoft OLE DB Provider for Jet gehen. Die CHECK-Einschränkung ermöglicht die Erstellung von Geschäftsregeln, die eine vollständige Tabelle bzw. mehrere andere Tabellen umfassen.


Kopierpuffer <Jet-Definition>

Kopierpuffer

Ein Speicherbereich, der vom Microsoft® Jet-Datenbankmodul angelegt wird, um den Inhalt eines Datensatzes aufzunehmen, der zum Bearbeiten geöffnet ist. Die Edit-Methode kopiert den aktuellen Datensatz in den Kopierpuffer, die AddNew-Methode löscht den Puffer für einen neuen Datensatz und legt die Standardwerte fest, und die Update-Methode speichert die Daten aus dem Kopierpuffer in der Datenbank, wobei der aktuelle Datensatz ersetzt oder der neue Datensatz eingefügt wird. Jede Anweisung, die den Zeiger auf den aktuellen Datensatz zurücksetzt oder verschiebt, führt zum Verlust des Kopierpufferinhalts. Beim Ausführen der MoveNext-Methode oder Ändern der Index-Eigenschaft einer Tabelle geht z. B. der Inhalt des Kopierpuffers verloren.


Korrelationsname <Jet-Definition>

Korrelationsname

Die ANSI-Definition eines Namens, der auf eine Spalte in einer Tabelle oder Ansicht (gespeicherte Abfrage) verweist. Wird auch als Aliasname bezeichnet.


Autowert (Datentyp) <Jet-Definition>

Autowert (Datentyp)

Ein Attribut für ein Feld, das für jeden Datensatz automatisch eine eindeutige Zahl speichert, wenn dieser einer Tabelle hinzugefügt wird. Ein Autowert-Feld verwendet den Datentyp Long, und seine Attributes-Eigenschaft ist auf dbAutoIncrement eingestellt. Mit einem Autowert-Feld erzeugte Zahlen können nicht geändert werden, es sei denn, der Tabelle wurde mit Hilfe von Grant- oder Revoke-Anweisungen in der SQL DDL-Syntax eine spezielle Berechtigung erteilt. Das Autowert-Feld wird auch als Zähler- oder Identitäts-Datentyp bezeichnet.

Anmerkung Bei replizierten Tabellen in replizierbaren Datenbanken werden Autowert-Felder nicht mit 1 inkrementiert. Statt dessen wird ein Zufallswert zwischen -2.000.000.000 und 2.000.000.000 zugewiesen.

Siehe auch

Identitätsattribut


Kriterien <Jet-Definition>

Kriterien

Eine Reihe einschränkender Bedingungen, z. B. = "Dänemark" (gleich Dänemark) oder > 30.000, die beim Erstellen einer Abfrage oder eines Filters verwendet werden, um eine bestimmte Gruppe von Datensätzen anzuzeigen.


Kreuztabellenabfrage <Jet-Definition>

Kreuztabellenabfrage

Eine Abfrage, die eine Summe, einen Mittelwert oder eine Anzahl berechnet bzw. eine andere Art von Berechnung an Datensätzen durchführt, und das Ergebnis dann nach zwei Arten von Informationen gruppiert anzeigt - die eine am linken, die andere am oberen Rand des Datenblatts. Die Abfrage "Bestellungen nach Artikel (Vierteljährlich)" in der Beispieldatenbank Nordwind ist z. B. eine Kreuztabellenabfrage.


Steuerzeichen <Jet-Definition>

Steuerzeichen

Eine Tastenkombination, die mit der STRG- oder ESC-Taste beginnt.


Currency (Datentyp) <Jet-Definition>

Currency (Datentyp)

Ein Datentyp, der bei Berechnungen hilfreich ist, die Währungsbeträge verwenden, oder bei Berechnungen mit einer festgelegten Anzahl von Nachkommastellen, bei denen die Genauigkeit besonders wichtig ist. Dieser Datentyp wird verwendet, um Zahlen mit bis zu 15 Vorkommastellen und 4 Nachkommastellen zu speichern. Der Datentyp Currency verwendet ganze Werte für alle Beträge, d. h. binäre Rundungen spielen beim Berechnen von Summen keine Rolle.


Aktuelle Datenbank <Jet-Definition>

Aktuelle Datenbank

Das Database-Objekt, das von der Funktion CurrentDB() zurückgegeben wird. Ein Verweis auf DBEngine.Workspaces(0).Databases(0) gibt die erste geöffnete Datenbank zurück. Dieses Konzept wird nur von Microsoft® Access unterstützt.


Aktueller Index <Jet-Definition>

Aktueller Index

Bei einem indizierten Recordset-Objekt vom Typ Tabelle ist dies der Index, der zuletzt mit der Index-Eigenschaft festgelegt wurde. Dieser Index bildet die Grundlage für das Sortieren von Datensätzen in einem Recordset-Objekt vom Typ Tabelle und wird von der Seek-Methode verwendet, um Datensätze zu finden. Ein Recordset-Objekt kann über mehrere Indizes verfügen, kann aber jeweils nur einen Index verwenden (obwohl ein TableDef-Objekt mehrere Indizes darauf definiert haben kann). Das Microsoft Jet-Datenbankmodul kann mehrere Indizes verwenden, um eine Abfrage auszuwerten.


Aktueller Datensatz <Jet-Definition>

Aktueller Datensatz

Der Datensatz in einem Recordset-Objekt, den Sie verwenden können, um Daten zu verändern oder zu untersuchen. Verwenden Sie die Move-Methoden, um die Position des aktuellen Datensatzes in einer Datensatzgruppe zu verändern. Verwenden Sie die Find-Methoden (mit einem Recordset-Objekt vom Typ Dynaset oder Snapshot) oder die Seek-Methode (mit einem Recordset-Objekt vom Typ Tabelle), um die Position des aktuellen Datensatzes nach bestimmten Kriterien zu ändern.

Nur ein Datensatz in einem Recordset-Objekt kann der aktuelle Datensatz sein, aber es kann auch ein Recordset-Objekt ohne einen aktuellen Datensatz geben. Nachdem z. B. ein Datensatz aus einem Recordset-Objekt vom Typ Dynaset gelöscht wurde, oder wenn ein Recordset-Objekt keine Datensätze enthält, ist der aktuelle Datensatz nicht definiert. In diesem Fall lösen Operationen, die sich auf den aktuellen Datensatz beziehen, einen auffangbaren Fehler aus.


Aktuelle Transaktion <Jet-Definition>

Aktuelle Transaktion

Alle an einem Recordset-Objekt vorgenommenen Änderungen, nachdem Sie das letzte Mal die BeginTrans-Methode verwendet haben und bevor Sie die Methode Rollback oder CommitTrans verwenden.


Datenzugriffsobjekte (DAO) <Jet-Definition>

Datenzugriffsobjekte (DAO)

Eine Programmierschnittstelle zum Zugreifen auf und Bearbeiten von Datenbankobjekten.


DAO-Objekt <Jet-Definition>

DAO-Objekt

Ein Objekt, das von der Datenzugriffsobjektbibliothek (Data Access Objects = DAO) definiert wird. Sie können DAO-Objekte, wie z. B. Database-, TableDef-, Recordset- und QueryDef-Objekte verwenden, um Objekte darzustellen, mit denen Daten (z. B. Tabellen und Abfragen) verwaltet und bearbeitet werden.


Datenbankmodul <Jet-Definition>

Datenbankmodul

Der Teil des Datenbanksystems, der Daten aus Benutzer- und Systemdatenbanken abruft und Daten darin speichert.


DDL (Data Definition Language = Datendefinitionssprache) <Jet-Definition>

DDL (Data Definition Language = Datendefinitionssprache)

Die Sprache, die verwendet wird, um die Attribute einer Datenbank (insbesondere Tabellen, Felder, Indizes und Speicherstrategie) zu beschreiben. ANSI legt dies fest, um über die Token CREATE, DROP und ALTER zu verfügen.


Datendefinitionsabfrage <Jet-Definition>

Datendefinitionsabfrage

Eine SQL-spezifische Abfrage, die eine Tabelle in einer Datenbank erstellen, verändern oder löschen bzw. einen Index in einer Datenbank erstellen oder löschen kann. ANSI bezeichnet diese als DDL-Abfragen und verwendet die Token CREATE, DROP und ALTER.

Siehe auch

DDL (Data Definition Language)


Datenquelle <Jet-Definition>

Datenquelle

Eine ODBC-Ressource (ODBC = Open DataBase Connectivity) mit einem Namen, die den Pfad, Treibertyp und andere von einem ODBC-Treiber benötigten Informationen angibt, um auf eine ODBC-Datenbank zuzugreifen. Jedes Objekt, das Daten zur Verfügung stellt, kann eine Datenquelle sein.


Datentyp <Jet-Definition>

Datentyp

Die Merkmale einer Variablen, die festlegen, welche Art von Daten gespeichert werden können. Zu diesen Datentypen gehören Big Integer, Binary, Byte, Boolean, Char, Currency, Date, Decimal, Double, Float, GUID, Integer, Long, Long Binary (OLE Object), Memo, Numeric, Single, String, Text, Time, TimeStamp, VarBinary, Variant (Voreinstellung), benutzerdefinierte Typen (die mit der Type-Anweisung erstellt werden) und Objektdatentypen, die wiederum durch den Host definierte Objektdatentypen und Typen von Datenzugriffsobjekten umfassen.


Datumsliteral <Jet-Definition>

Datumsliteral

Eine beliebige Zeichenfolge in gültigem Format, die von Nummernzeichen (#) eingeschlossen ist. Gültige Formate sind etwa Ihr lokales Datumsformat oder auch das universelle Datumsformat.

Wenn die Ländereinstellung für Ihre Anwendung auf Deutschland eingestellt ist, steht z. B. #30/9/75# für den 30. September 1975. Verwenden Sie Datumsliterale, um eine maximale Portierbarkeit über verschiedene Sprachen hinweg zu erreichen.


Datum und Uhrzeit <Jet-Definition>

Datum und Uhrzeit

Intern werden das Datum und die Uhrzeit als unterschiedliche Teile einer reellen Zahl gespeichert.

Der Wert links vom Dezimalkomma steht für ein Datum vom 30. Dezember 1899 bis zum 30. Dezember 9999 (einschließlich). Negative Werte stehen für Werte vor dem 30. Dezember 1899.

Der Wert rechts vom Dezimalkomma steht für eine Zeit zwischen 0:00:00 und 23:59:59 (einschließlich). Mittag wird durch .5 dargestellt.


Decimal (Datentyp) <Jet-Definition>

Decimal (Datentyp)

Ein Datentyp, der einen genauen numerischen Wert mit Vorzeichen mit der Präzision p und der Dezimalstelle s (1 ≤ p ≤15; 0 ≤ s ≤ p) speichert.


Standard-Arbeitsbereich <Jet-Definition>

Standard-Arbeitsbereich

Das Workspace-Objekt, das von DAO automatisch eingerichtet wird, wenn Ihre Anwendung zum ersten Mal auf ein DAO-Objekt verweist. Dieser Arbeitsbereich wird durch DBEngine.Workspaces(0) oder einfach Workspaces(0) angegeben.


Löschabfrage <Jet-Definition>

Löschabfrage

Eine Aktionsabfrage, die eine Gruppe von Zeilen löscht, die die von Ihnen angegebene Kriterien erfüllen. Eine Löschabfrage gibt keine Zeilen zurück.


Entwurfszeit <Jet-Definition>

Entwurfszeit

Der Zeitraum, in dem Sie in der Entwicklungsumgebung eine Anwendung erstellen, indem Sie Steuerelemente hinzufügen, Eigenschaften von Steuerelementen und Formularen festlegen usw. Im Gegensatz dazu arbeiten Sie zur Laufzeit interaktiv mit der Anwendung wie ein Benutzer.


Zielfeld <Jet-Definition>

Zielfeld

Ein Feld in einer Abfrage, das das Ergebnis Ihrer Abfrage enthält.


Direkte Synchronisierung <Jet-Definition>

Direkte Synchronisierung

Eine Art von Synchronisierung, die auftritt, wenn die zwei Replikate gleichzeitig während des Synchronisierungsvorgangs geöffnet werden können.


DLL (Dynamic Link Library) <Jet-Definition>

DLL (Dynamic Link Library)

Eine Reihe von Routinen, die von Prozeduren aufgerufen werden können. Sie werden zur Laufzeit von der Anwendung geladen und verknüpft.


Double (Datentyp) <Jet-Definition>

Double (Datentyp)

Ein grundlegender Datentyp, der Fließkommawerte doppelter Genauigkeit nach dem IEEE-Format speichert. Eine Variable vom Typ Double wird als Zahl mit 64 Bits (8 Bytes) gespeichert und kann einen Wert aus dem Bereich von -1,79769313486231E308 bis -4,94065645841247E-324 (negativ) bzw. von 4,94065645841247E-324 bis 1.79769313486231E308 (positiv) sowie den Wert 0 aufnehmen.


Dynamischer Cursor <Jet-Definition>

Dynamischer Cursor

Eine dynamische Gruppe von Zeilen, mit denen Zeilen in einer zugrundeliegenden Datenbanktabelle oder Tabelle hinzugefügt, geändert oder gelöscht werden können. Ein dynamischer Cursor kann Spalten einer oder mehrerer Tabellen einer Datenbank enthalten. Die Mitgliedschaft ist nicht festgelegt.


Dynaset <Jet-Definition>

Dynaset

Ein Typ des Recordset-Objekts, der eine dynamische Gruppe von Zeigern auf die tatsächlichen Daten einer Datenbank zurückgibt. Wie ein Recordset-Objekt vom Typ Tabelle oder Snapshot gibt ein Dynaset Daten in Datensätzen (Zeilen) und Feldern (Spalten) zurück. Im Gegensatz zu einem Recordset-Objekt vom Typ Tabelle kann ein Recordset-Objekt vom Typ Dynaset das Ergebnis einer Abfrage sein, bei der zwei oder mehr Tabellen miteinander verknüpft werden. Die Datensätze in einem Recordset-Objekt vom Typ Dynaset sind aktualisierbar, wenn die zugehörige Updatable-Eigenschaft den Wert True hat, das Feld des geänderten Field-Objekts aktualisierbar ist und die Datenseite mit dem aktuellen Datensatz nicht gesperrt ist. Die Datenseite ist gesperrt, wenn die Update-Methode (wenn die LockEdits-Eigenschaft den Wert False hat), oder die Edit-Methode verwendet wird (wenn die LockEdits-Eigenschaft den Wert True hat).


Gleichheitsverknüpfung <Jet-Definition>

Gleichheitsverknüpfung

Eine Verknüpfung, in der Datensätze aus zwei Tabellen nur dann kombiniert und zum Recordset-Objekt hinzugefügt werden, wenn die verknüpften Felder dieselben Werte enthalten. Wird auch als Exklusionsverknüpfung bezeichnet.


Exklusiv <Jet-Definition>

Exklusiv

Eine Zugriffsart, die die Daten in einer Datenbank bei gemeinsamer Nutzung in einem Netzwerk schützt. Wenn Sie eine Datenbank im exklusiven Modus öffnen, hindern Sie andere am Öffnen der Datenbank.


Ausdruck <Jet-Definition>

Ausdruck

Eine beliebige Kombination aus Operatoren, Konstanten, Literalwerten, Funktionen und Namen von Feldern, Steuerelementen und Eigenschaften, die einen einzelnen Wert ergibt. Sie können Ausdrücke als Einstellungen für viele Eigenschaften und als Aktionsargumente verwenden, um Kriterien festzulegen oder berechnete Felder in Abfragen zu definieren.


Externe Datenbank <Jet-Definition>

Externe Datenbank

Entweder eine ODBC-Datenbank wie Microsoft® SQL Server™, die auf einem Netzwerkserver gespeichert ist, oder eine der externen Datenbanken wie Paradox, dBASE, FoxPro®, Microsoft Excel, Microsoft Access, Lotus1-2-3, HTML und Text.


Externe Tabelle <Jet-Definition>

Externe Tabelle

Eine Tabelle in einer Datenbank außerhalb der geöffneten Microsoft® Jet-Datenbank. Eine externe Tabelle kann eine andere Datei sein oder eine Tabelle in einer anderen relationalen Datenbank.


Feld <Jet-Definition>

Feld

Eine Kategorie von Informationen, die in einer Tabelle einer Datenbank gespeichert sind: eine Spalte mit Daten. Ein Element einer Datenbanktabelle, das eine bestimmte Information enthält, z. B. den Nachnamen.


Feldeigenschaften <Jet-Definition>

Feldeigenschaften

Attribute eines Feldes, die die im Feld enthaltenen Daten festlegen. Die Eigenschaften Size (für die Größe) und Type (für den Typ) sind Beispiele.


Filter <Jet-Definition>

Filter

Eine Gruppe von Kriterien, die Datensätze erfüllen müssen, um eine Untermenge der Datensätze zu erstellen.


Float (Datentyp) <Jet-Definition>

Float (Datentyp)

Ein Datentyp, der einen ungefähren numerischen Wert mit Vorzeichen mit der Mantisse-Präzision 15 (Null- oder absoluter Wert 10-308 bis 10308) speichert.


Fremdschlüssel <Jet-Definition>

Fremdschlüssel

Ein oder mehrere Tabellenfelder, die auf die Primärschlüsselfelder in einer anderen Tabelle verweisen. Ein Fremdschlüssel zeigt an, wie Tabellen zueinander in Beziehung stehen, die Daten im Fremdschlüssel- und im Primärschlüsselfeld müssen übereinstimmen. Eine Liste gültiger Artikelnummern enthält z. B. einen Fremdschlüssel auf einer Inventartabelle, der Verweise auf gültige Artikelnummern enthält. Fremdschlüssel werden verwendet, wenn die referenzielle Integrität für eine Datenbank sichergestellt werden soll.


Fremdtabelle <Jet-Definition>

Fremdtabelle

Eine Tabelle, die einen Fremdschlüssel für eine andere Tabelle in der Datenbank bereitstellt. Im allgemeinen verwenden Sie eine Fremdtabelle, um die referenzielle Integrität einzurichten. Die Fremdtabelle befindet sich in der Regel auf der n-Seite einer 1:n-Beziehung. Ein Beispiel für eine Fremdtabelle ist eine Tabelle mit Kundenbestellungen.


Formular <Jet-Definition>

Formular

Ein Fenster oder ein Dialogfeld, das auch als Form oder Maske bezeichnet wird. Ein Formular stellt einen Container für Steuerelemente dar. Ein MDI-Formular (MDI = multiple document interface) kann auch einen Container für untergeordnete Formulare und bestimmte Steuerelemente darstellen.


Vorwärts-Cursor <Jet-Definition>

Vorwärts-Cursor

Eine Ergebnismenge, bei der die aktuelle Position nur um eine bestimmte Anzahl an Datensätzen vorwärts bewegt werden kann, oder der letzte Datensatz. Die aktuelle Position kann nicht zurück auf den Anfang der Ergebnismenge oder auf den vorherigen Datensatz gesetzt werden. Die Elemente, Reihenfolge und Werte des Cursors werden normalerweise festgelegt, wenn der Cursor geöffnet wird. Wenn andere Benutzer Zeilen aktualisieren, löschen oder einfügen, zeigt der Cursor dies erst dann an, wenn er geschlossen und erneut geöffnet wird.


Vorwärtsbewegung <Jet-Definition>

Vorwärtsbewegung

Eine Bewegung in Richtung Ende (EOF) eines Recordset-Objekts.


Recordset-Objekt vom Typ Vorwärts <Jet-Definition>

Recordset-Objekt vom Typ Vorwärts

Ein Recordset-Objekt, in dem nach Datensätzen nur in Vorwärtsrichtung (vom Anfang in Richtung Ende) gesucht werden kann; die aktuelle Datensatzposition kann nicht auf den ersten Datensatz zurückgesetzt werden. In Recordset-Objekten vom Typ Vorwärts ist der Verwaltungsaufwand beim Bearbeiten von Remote-Datenbanken im Netzwerk geringer. Sie können ein Recordset-Objekt vom Typ Vorwärts z. B. verwenden, um in einer verknüpften Fremdtabelle Daten schnell in einem Durchgang zu verarbeiten (z. B. wenn Sie einen benutzerdefinierten Bericht erstellen).


FTP <Jet-Definition>

FTP

Dateiübertragungsprotokoll (File Transfer Protocol). Mit diesem Protokoll können Benutzer Dateien von einer Internet-Adresse an eine andere übertragen. URLs von Dateien auf einem FTP-Server beginnen mit ftp://.


Function-Prozedur <Jet-Definition>

Function-Prozedur

Eine Prozedur, die eine bestimmte Aufgabe in einem Microsoft® Visual Basic®-Programm ausführt und einen Wert zurückgibt. Eine Function-Prozedur beginnt mit einer Function-Anweisung und endet mit der End Function-Anweisung.


Gruppe <Jet-Definition>

Gruppe

Eine Zusammenfassung von Benutzerkonten in einem Workgroup-Objekt, die durch einen Gruppennamen und eine persönliche ID (PID) gekennzeichnet ist. Einer Gruppe zugeteilte Berechtigungen gelten für alle Benutzer in der Gruppe.


GUID (Datentyp) <Jet-Definition>

GUID (Datentyp)

Global eindeutiger Bezeichner (Globally Unique Identifier) oder auch universell eindeutiger Bezeichner (Universally Unique Identifier). Eine Zeichenfolge, die als eindeutiger Bezeichner dient und für RPC (Remote Procedure Calls = computerübergreifende Prozeduraufrufe) verwendet wird. Jede Schnittstelle und Objektklasse verwendet einen GUID-Wert zur Identifizierung. Ein GUID-Wert umfasst 128 Bits. Ein syntaktisch korrekter GUID-Wert ist z. B. 12345678-1234-1234-1234-123456789ABC. Die GUID-Werte müssen auf dem Client und dem Server übereinstimmen, damit sich der Client und der Server verbinden können. Anbieter von Objekten können von Microsoft die Reservierung einer oder mehrerer Gruppen aus jeweils 256 GUID-Werten für die exklusive Nutzung anfordern. Wenn Sie über eine Netzwerkkarte verfügen, können Sie auch alternativ ein Programm namens Uuidgen.exe ausführen, das 256 GUID-Werte basierend auf der Tageszeit, dem Datum und einer eindeutigen Nummer der Netzwerkkarte bereitstellt.


HTTP <Jet-Definition>

HTTP

Hypertextübertragungsprotokoll (Hypertext Transfer Protocol). Das Internet-Protokoll, das im Hintergrund die Informationen über das World Wide Web bereitstellt. Das Protokoll ermöglicht Benutzern, über ein Client-Programm einen URL einzugeben (oder auf einen Hyperlink zu klicken) und Text, Grafiken, Klänge und andere digitale Informationen von einem Web Server abzurufen. URLs von Dateien auf Web Servern beginnen mit http://.


Hyperlink (Datentyp) <Jet-Definition>

Hyperlink (Datentyp)

Ein Felddatentyp, mit dem Sie Hyperlinks speichern können. Hyperlink-Felder enthalten Text oder eine Kombination aus Text und Zahlen, die als Text gespeichert sind, der als Hyperlink-Adresse verwendet wird. Eine Hyperlink-Adresse kann aus drei Teilen bestehen (wobei jeder Teil bis zu 2048 Zeichen enthalten kann); folgende Syntax wird verwendet:

Anzeigetext#Adresse#Sub-Adresse


Identitätsattribut <Jet-Definition>

Identitätsattribut

Wurde hinzugefügt, um eine syntaktische Äquivalenz zu SQL Server bereitzustellen. Nur verfügbar, wenn SQL DDL von Microsoft® OLE DB Provider for Jet aus verwendet wird. Dieser Datentyp verfügt über dieselbe Funktionalität wie der Zählerfeld- und Autowert-Datentyp. Es handelt sich hierbei um ein Synonym und hat keine zusätzliche Funktionalität.

Siehe auch

Autowert-Feld


Inkonsistent <Jet-Definition>

Inkonsistent

Der Zustand eines Recordset-Objekts über mehrere Tabellen, in dem Sie alle Felder (Spalten) aktualisieren können. Beispielsweise können Sie in einem Recordset-Objekt, das durch die Verknüpfung zweier Tabellen in einer 1:n-Verknüpfung erstellt wird (wie bei einer Tabelle "Kunden" und einer Tabelle "Bestellungen"), die Kundenkennung in der Tabelle "Bestellungen" (Bestellungen.KundenID) in einen Wert ändern, der mit keiner Kundenkennung in der Tabelle "Kunden" (Kunden.KundenID) übereinstimmt, es sei denn, dass Aktualisierungen durch referenzielle Integrität deaktiviert werden.


Inkrementwert <Jet-Definition>

Inkrementwert

Optionaler Parameter, der mit den Counter- oder Identity-Datentypen verwendet wird. In SQL DDL nur verfügbar, wenn Microsoft® OLE DB Provider for Jet verwendet wird. Es handelt sich dabei um den Wert, der zum Zuordnen des nächsten Werts einer neuen Zeile in einer Tabelle verwendet wird, die einen Counter- oder Identity-Datentyp enthält. Der Inkrementwert ist der zweite von zwei optionalen Parametern für Counter- oder Identity-Datentypen.

Siehe auch

Ausgangswert


Index <Jet-Definition>

Index

Ein dynamischer Querverweis auf ein oder mehrere Datenfelder (Spalten) einer Tabelle, der ein schnelleres Abrufen bestimmter Datensätze aus einer Tabelle ermöglicht. Beim Hinzufügen, Ändern oder Löschen von Datensätzen aktualisiert das Datenbankmanagement-System automatisch den Index entsprechend den vorgenommenen Änderungen.

Ein aktueller Index, der mit einem Recordset-Objekt vom Typ Tabelle verwendet wird, bestimmt die Reihenfolge, in der Datensätze in das Recordset-Objekt zurückgegeben werden. Für eine Tabelle können mehrere Indizes auf den Daten definiert sein.

Ein DAO-Index-Objekt stellt einen Index für ein TableDef-Objekt dar.


Indirekte Synchronisierung <Jet-Definition>

Indirekte Synchronisierung

Eine Art der Synchronisierung, die auftritt, wenn ein Synchronizer in einem Ablageordner für einen anderen Synchronizer Änderungen hinterlässt, die dieser übernimmt, und sie auf das von ihm verwaltete Replikat anwendet.


Exklusionsverknüpfung <Jet-Definition>

Exklusionsverknüpfung

Eine Verknüpfung, in der Datensätze aus zwei Tabellen nur dann kombiniert und zum Recordset-Objekt hinzugefügt werden, wenn die verknüpften Felder eine angegebene Bedingung erfüllen. Beispielsweise ist eine Gleichheitsverknüpfung eine Exklusionsverknüpfung, in der die Werte der verknüpften Felder gleich sein müssen.


Installierbares ISAM <Jet-Definition>

Installierbares ISAM

Ein Treiber, den Sie angeben können und der einen Zugriff auf externe Datenbankformate wie dBASE, Microsoft® Excel und Paradox ermöglicht. ISAM ist ein Akronym für Indexed Sequential Access Method (Indexsequenzielle Zugriffsmethode). Das Microsoft Jet-Datenbankmodul installiert (lädt) diese ISAM-Treiber, wenn in Ihrer Anwendung darauf verwiesen wird. Der Pfad dieser Treiber wird in der Microsoft Windows®-Registrierung verwaltet.


Instanz <Jet-Definition>

Instanz

Ein beliebiges Objekt aus einer Gruppe von Objekten einer bestimmten Klasse. Mehrere Instanzen z. B. der Klasse Form nutzen denselben Code und werden mit denselben Steuerelementen geladen, mit denen die Klasse Form ursprünglich entworfen wurde. Zur Laufzeit können die einzelnen Eigenschaften von Steuerelementen für jede Instanz auf unterschiedliche Werte gesetzt werden.


Integer (Datentyp) <Jet-Definition>

Integer (Datentyp)

Ein grundlegender Datentyp, der ganzzahlige Werte speichert. Eine Variable vom Typ Integer wird als Zahl mit 16 Bits (2 Bytes) gespeichert und kann einen Wert im Bereich von -32.768 bis 32.767 aufnehmen.


Internet <Jet-Definition>

Internet

Ein weltweites Netzwerk, das wiederum aus Tausenden von kleineren Computernetzwerken und Millionen von Computern aus den Bereichen Handel, Bildung, Regierung und privaten Computern besteht. Das Internet ist wie eine elektronische Stadt mit virtuellen Bibliotheken, Schaufenstern, Büros, Galerien usw.


Internet-Synchronisierung <Jet-Definition>

Internet-Synchronisierung

Ein Synchronisierungstyp, der einen mehrfachen Nachrichtenaustausch zwischen Replikaten voraussetzt, die sich in einem Ablageordner befinden. Nur das Replikat, das vom Synchronizer auf dem Internet-Server verwaltet wird, besitzt einen Ablageordner. Auf diesen Ablageordner können Sie über eine HTTP- oder FTP-Verbindung zugreifen.


Intranet <Jet-Definition>

Intranet

Ein Netzwerk innerhalb einer Organisation, das die Internet-Technologien (wie z. B. die Protokolle HTTP oder FTP) nutzt. Sie können sich in einem Intranet mit Hyperlinks zwischen Objekten, Dokumenten, Webseiten usw. bewegen.


Eingebaute Konstante <Jet-Definition>

Eingebaute Konstante

Eine Konstante, die von Anwendungen bereitgestellt wird. Konstanten von Datenzugriffsobjekten (DAO) werden z. B. in der DAO-Objektbibliothek aufgeführt und können mit dem Objektkatalog angezeigt werden.


Mit Microsoft Jet verbundene ODBC-Datenquelle <Jet-Definition>

Mit Microsoft Jet verbundene ODBC-Datenquelle

Eine ODBC-Datenquelle, auf die mit Datenzugriffsobjekten (DAO) und dem Microsoft® Jet-Datenbankmodul zugegriffen werden kann.


Verknüpfung <Jet-Definition>

Verknüpfung

Eine Datenbankoperation, in der einige oder alle Datensätze aus mindestens zwei Tabellen kombiniert werden, z. B. eine Gleichheits-, Inklusions-, Exklusions- oder Reflexivverknüpfung. Allgemein bezieht sich eine Verknüpfung auf eine Zuordnung eines Feldes einer Tabelle zu einem Feld desselben Datentyps einer anderen Tabelle. Sie erstellen eine Verknüpfung mit einer SQL-Anweisung.

Wenn Sie eine Beziehung zwischen zwei Tabellen definieren, erstellen Sie eine Verknüpfung, indem Sie die Felder der Primärtabelle und der Fremdtabelle angeben. Wenn Sie eine Tabelle zu einer Abfrage hinzufügen, erstellen Sie eine Verknüpfung zwischen den entsprechenden Feldern in der SQL-Anweisung, die die Abfrage definiert.


Schlüsselgruppen-Cursor <Jet-Definition>

Schlüsselgruppen-Cursor

Eine Gruppe von Zeilen, mit der Sie einer zugrundeliegenden Datenbanktabelle oder Tabelle Zeilen hinzufügen können oder diese darin ändern oder löschen können. Sie können sich innerhalb einer Schlüsselgruppe unbegrenzt bewegen. Ein Schlüsselgruppen-Cursor kann Spalten aus einer oder mehreren Tabellen einer Datenbank enthalten. Die Mitgliedschaft ist festgelegt.


Linke Verknüpfung <Jet-Definition>

Linke Verknüpfung

Eine linke Verknüpfung enthält alle Datensätze der ersten (linken) von zwei Tabellen, auch wenn es keine übereinstimmenden Werte für Datensätze in der zweiten (rechten) Tabelle gibt.


Linke Inklusionsverknüpfung <Jet-Definition>

Linke Inklusionsverknüpfung

Eine Inklusionsverknüpfung, in der alle Datensätze von der linken Seite der LEFT JOIN-Operation in der SQL-Anweisung einer Abfrage zum Recordset-Objekt hinzugefügt werden, auch wenn es keine entsprechenden Werte in dem verknüpften Feld der Tabelle auf der rechten Seite gibt. Datensätze aus der rechten Tabelle werden nur dann mit Datensätzen aus der linken Tabelle verknüpft, wenn es übereinstimmende Werte in den verknüpften Feldern gibt. Wenn ein Datensatz auf der linken Seite keine Entsprechung hat, wird auf der rechten Seite eine Zeile mit Null-Werten verknüpft.


Verknüpfte Tabelle <Jet-Definition>

Verknüpfte Tabelle

Eine Tabelle in einer anderen Datenbank, die mit einer Microsoft® Jet-Datenbank verknüpft ist. Die Daten für verknüpfte Tabellen verbleiben in der externen Datenbank, in der sie von anderen Anwendungen bearbeitet werden können. (Bisher wurden diese Tabellen als eingebundene Tabellen bezeichnet.)


Gesperrt <Jet-Definition>

Gesperrt

Der Zustand einer Datenseite eines Recordset-Objekts oder eines Database-Objekts, bei dem das Objekt für alle Benutzer, mit Ausnahme des Benutzers, der momentan Daten eingibt, schreibgeschützt ist.


Long Binary (Datentyp) <Jet-Definition>

Long Binary (Datentyp)

Ein Feldtyp der Datenmengen bis zu 2,14 GB enthalten kann. Felder vom Typ Long Binary können alle Arten von binären Daten enthalten. In Microsoft® Access wird dieser Datentyp als OLE-Objekt bezeichnet.


Long (Datentyp) <Jet-Definition>

Long (Datentyp)

Ein grundlegender Datentyp, der lange ganzzahlige Zahlen speichert. Eine Variable vom Typ Long ist eine Zahl mit 32 Bits (4 Bytes) im Bereich von -2.147.483.648 bis 2.147.483.647.


Tabellenerstellungsabfrage <Jet-Definition>

Tabellenerstellungsabfrage

Eine Aktionsabfrage, die eine neue Tabelle aus dem Recordset-Objekt einer bestehenden Abfrage erstellt.


Nur-n-Tabelle <Jet-Definition>

Nur-n-Tabelle

Eine Tabelle, die nicht als 1-Seite einer Verknüpfung in einer Abfrage erscheint.


Memo (Datentyp) <Jet-Definition>

Memo (Datentyp)

Ein Felddatentyp. Solche Felder können bis zu 2,14 GB Textdaten enthalten.


Nachricht <Jet-Definition>

Nachricht

Ein Informationspaket, das von einer Anwendung an eine andere übergeben wird.


Methode <Jet-Definition>

Methode

Eine Prozedur, ähnlich wie eine Funktion. Eine Methode führt Operationen auf bestimmten Objekten aus.


Microsoft Jet-Datenbank <Jet-Definition>

Microsoft Jet-Datenbank

Eine Datenbank, die mit dem Microsoft® Jet-Datenbankmodul erstellt wurde. Die Dateinamenerweiterung einer Microsoft Jet-Datenbank ist .mdb.


Microsoft Jet-Arbeitsbereich <Jet-Definition>

Microsoft Jet-Arbeitsbereich

Ein Arbeitsbereich, der das Microsoft® Jet-Datenbankmodul zum Zugreifen auf Datenquellen verwendet. Die Datenquelle kann eine Microsoft Jet-Datenbankdatei (.mdb), eine ODBC-Datenbank, wie z. B. eine Paradox-Datenbank, oder eine ISAM-Datenbank sein.


Felddatentypen <Jet-Definition>

Felddatentypen

In der folgenden Tabelle werden die Felddatentypen aufgeführt.

DAO-Felddatentyp | Konstante
Big Integer | DbBigInt
Binary | DbBinary
Boolean | DbBoolean
Byte | DbByte
Char | DbChar
Currency | DbCurrency
Date/Time | DbDate
Decimal | DbDecimal
Double | DbDouble
Float | DbFloat
GUID | DbGUID
Integer | DbInteger
Long | DbLong
Long Binary (OLE-Objekt) | DbLongBinary
Memo | DbMemo
Numeric | DbNumeric
Single | DbSingle
Text | DbText
Time | DbTime
TimeStamp | DbTimeStamp
VarBinary | DbVarBinary


Microsoft Jet-Datenbankmodul <Jet-Definition>

Microsoft Jet-Datenbankmodul

Ein Datenbankmanagement-System, das Daten aus Benutzer- und Systemdatenbanken abruft und darin speichert. Das Microsoft® Jet-Datenbankmodul ist eine Komponente zur Datenverwaltung, mit der andere Anwendungen mit Möglichkeit zum Datenzugriff (wie Microsoft Access und Microsoft Visual Basic®) erstellt werden. In anderen Anwendungen wird das Datenbankmodul auch Datenbank-Engine genannt.


Mehrbenutzerdatenbank <Jet-Definition>

Mehrbenutzerdatenbank

Eine Datenbank, die mehreren Benutzern erlaubt, gleichzeitig auf dieselben Daten zuzugreifen und diese zu verändern. Manchmal kann der andere Benutzer eine weitere Instanz Ihrer oder einer anderen Anwendung sein, die auf Ihrem System ausgeführt wird und auf dieselben Daten zugreift wie eine andere Anwendung.


Normalisieren <Jet-Definition>

Normalisieren

Minimieren der redundanten (mehrfach vorhandenen) Informationen in einer relationalen Datenbank durch effizienten Tabellenentwurf.


Null <Jet-Definition>

Null

Ein Wert, der fehlende oder unbekannte Daten anzeigt. Null-Werte können in Felder eingegeben werden, für die keine Informationen bekannt sind, oder in Ausdrücke und Abfragen. In Visual Basic weist das Schlüsselwort Null auf einen Null-Wert hin. Einige Felder, z. B. Felder, die per Definition den Primärschlüssel enthalten, können keine Null-Werte enthalten.


Nullfeld <Jet-Definition>

Nullfeld

Ein Feld, das keine Zeichen oder Werte enthält. Ein Nullfeld ist nicht dasselbe wie eine Null-Zeichenfolge ("") oder ein Feld mit dem Wert 0. Ein Feld wird auf Null gesetzt, wenn der Inhalt des Feldes unbekannt ist. Beispielsweise enthält das Feld Vollendungsdatum in einer Vorgangstabelle so lange den Nullwert, bis ein Vorgang abgeschlossen ist.


Numeric (Datentyp) <Jet-Definition>

Numeric (Datentyp)

Ein Datentyp, der einen genauen numerischen Wert mit Vorzeichen mit der Präzision p und der Dezimalstelle s (1 ≤ p ≤15; 0 ≤ s ≤ p) speichert.


Numerischer Ausdruck <Jet-Definition>

Numerischer Ausdruck

Jeder Ausdruck, der eine Zahl zurückgibt. Dies kann eine beliebige Kombination von Variablen, Konstanten, Funktionen und Operatoren sein, die als Ergebnis eine Zahl liefert.


Objektkatalog <Jet-Definition>

Objektkatalog

Ein Dialogfeld, mit dem Sie den Inhalt einer Objektbibliothek untersuchen können, um Informationen über die zur Verfügung stehenden Objekte zu erhalten.


Objektausdruck <Jet-Definition>

Objektausdruck

Ein Ausdruck, der ein bestimmtes Objekt angibt. Dieser Ausdruck kann jeden der Container eines Objekts beinhalten. Ist in Ihrer Anwendung z. B. ein Application-Objekt enthalten, das ein Document-Objekt mit wiederum einem Text-Objekt enthält, sind die folgenden Ausdrücke gültige Objektausdrücke:

Application.Document.Text

Application.Text

Document.Text

Text


Objektbibliothek <Jet-Definition>

Objektbibliothek

Eine Dynamic Link Library (DLL) mit einer oder mehreren Typ-Bibliotheksressourcen, die normalerweise die Erweiterung .OLB hat. Sie können den Objektkatalog verwenden, um den Inhalt einer Objektbibliothek auf Informationen über die zur Verfügung gestellten Objekte hin zu untersuchen.


Objektvariable <Jet-Definition>

Objektvariable

Eine Variable, die einen Verweis auf ein Objekt enthält.


ODBC (Open Database Connectivity) <Jet-Definition>

ODBC (Open Database Connectivity)

Ein Standardprotokoll, über das Anwendungen Verbindungen zu einer Vielzahl externer Datenbankserver oder -dateien herstellen können. ODBC-Treiber, die vom Microsoft® Jet-Datenbankmodul verwendet werden, erlauben den Zugriff auf Microsoft SQL Server™ und verschiedene andere externe Datenbanken.

Das ODBC-API (Application Programming Interface) kann auch verwendet werden, um auf ODBC-Treiber und durch sie verbundene Datenbanken zuzugreifen und dabei das Microsoft Jet-Datenbankmodul zu umgehen.


ODBC-Datenquelle <Jet-Definition>

ODBC-Datenquelle

Ein Begriff für eine Datenbank oder einen Datenbankserver, die/der als Quelle für Daten verwendet wird. ODBC-Datenquellen werden mit Ihrem Datenquellennamen (DSN = Data Source Name) angegeben. Datenquellen können mit der Microsoft® Windows®-Systemsteuerung oder der RegisterDatabase-Methode erstellt werden.


ODBC-Treiber <Jet-Definition>

ODBC-Treiber

Eine Dynamic Link Library (DLL), die verwendet wird, um eine bestimmte ODBC-Datenquelle (ODBC = Open Database Connectivity) mit einer anderen Anwendung (Client) zu verbinden.


ODBC-Treiber-Manager <Jet-Definition>

ODBC-Treiber-Manager

Eine Anwendung, die die Verbindung zwischen Datenquellen, die durch ODBC aktiviert wurden, und den Datenquellentreibern verwaltet.


OLE (Object Linking and Embedding) <Jet-Definition>

OLE (Object Linking and Embedding)

Die auf Objekten basierende Technologie von Microsoft, mit der Sie Anwendungen erstellen können, die Komponenten von verschiedenen anderen Anwendungen enthalten


ActiveX-Objekt <Jet-Definition>

ActiveX-Objekt

Ein Objekt, auf das andere Anwendungen oder Programmierwerkzeuge durch Automatisierung von Schnittstellen (früher OLE-Automatisierung) zugreifen können. Microsoft® kann z. B. Microsoft ActiveX®-Objekte in Microsoft Word oder Microsoft Excel erstellen und verändern.


OLE-Objekt (Datentyp) <Jet-Definition>

OLE-Objekt (Datentyp)

Ein Felddatentyp, den Sie für Objekte verwenden, die in anderen Anwendungen erstellt werden und mit einer Microsoft® Jet-Datenbank verknüpft bzw. in diese eingebettet werden können. Beispielsweise können Sie ein Feld vom Typ OLE-Objekt zum Speichern einer Sammlung von Bildern verwenden.


1:n-Beziehung <Jet-Definition>

1:n-Beziehung

Eine Beziehung zwischen zwei Tabellen, bei der folgendes gilt:

  • Der Primärschlüsselwert aller Datensätze in der Primärtabelle stimmt mit dem Wert des entsprechenden Feldes oder der entsprechenden Felder von Datensätzen in der in Beziehung stehenden Tabelle überein.
  • Der Primärschlüsselwert aller Datensätze der in Beziehung stehenden Tabelle stimmt mit dem Wert des entsprechenden Feldes oder der entsprechenden Felder genau eines Datensatzes in der Primärtabelle überein.


1:1-Beziehung <Jet-Definition>

1:1-Beziehung

Eine Beziehung zwischen zwei Tabellen, bei der folgendes gilt:

  • Der Primärschlüsselwert aller Datensätze in der Primärtabelle stimmt mit dem Wert des entsprechenden Feldes oder der entsprechenden Felder genau eines Datensatzes in der in Beziehung stehenden Tabelle überein.
  • Der Primärschlüsselwert aller Datensätze der in Beziehung stehenden Tabelle stimmt mit dem Wert des entsprechenden Feldes oder der entsprechenden Felder genau eines Datensatzes in der Primärtabelle überein.


Eingeschränkt <Jet-Definition>

Eingeschränkt

Eine Sperrmethode, bei der die Datenseite, die einen oder mehrere Datensätze (u.a. den momentan bearbeiteten Datensatz) enthält, anderen Benutzern nur dann nicht zur Verfügung steht, wenn der Datensatz mit der Update-Methode aktualisiert wird, der aber ansonsten zwischen den Aufrufen der Edit- und Update-Methoden verfügbar ist. Eingeschränktes Sperren wird beim Zugriff auf ODBC-Datenbanken verwendet, oder wenn die LockEdits-Eigenschaft des Recordset-Objekts den Wert False hat.


Inklusionsverknüpfung <Jet-Definition>

Inklusionsverknüpfung

Eine Verknüpfung, in der alle Datensätze einer Tabelle zum Recordset-Objekt hinzugefügt werden, auch wenn keine übereinstimmenden Werte im verknüpften Feld aus der zweiten Tabelle vorhanden sind. Datensätze aus der zweiten Tabelle werden nur dann mit Datensätzen aus der ersten Tabelle kombiniert, wenn die verknüpften Felder übereinstimmende Werte enthalten. Null-Datensätze werden verknüpft, wenn es keine Übereinstimmung gibt.


Seite <Jet-Definition>

Seite

Ein Teil der Datenbank, in der Daten eines Datensatzes gespeichert werden. Je nach Größe der Datensätze kann eine Datenseite mehrere Datensätze enthalten. Eine Datenseite in einer Microsoft® Jet-Datenbank (.mdb) ist 2 KB (2048 Bytes) groß. Die Größe von Jet 4.X-Dateiformaten beträgt 4 KB (4096 Byte).


Parameter <Jet-Definition>

Parameter

Ein Element mit einem Wert, den Sie ändern können, um das Ergebnis der Abfrage zu beeinflussen. Eine Abfrage, die beispielsweise Daten zu einem Angestellten zurückgibt, kann einen Parameter für den Namen des Angestellten haben. Sie können dann ein QueryDef-Objekt verwenden, um Daten zu einem beliebigen Angestellten abzurufen, indem Sie den Parameter auf einen bestimmten Namen setzen, bevor Sie die Abfrage starten.

Beim Einsatz von Microsoft® OLE DB Provider for Jet unter Microsoft Jet, Version 4.x, können von Prozeduren aus auf Parameter zugegriffen werden, indem Sie das ANSI-Fragezeichen (?) als Parametermarke verwenden. Wenn Sie die SQL-Syntax verwenden, können Sie das Äquivalent zu einem QueryDef-Objekt erstellen.


Parameterabfrage <Jet-Definition>

Parameterabfrage

Eine Abfrage, bei der Sie ein oder mehrere Kriterien (z. B. "Dortmund" für "Stadt") angeben müssen, bevor die Abfrage ausgeführt wird. Eine Parameterabfrage ist keine Abfrage im eigentlichen Sinne, sondern sie erweitert die Flexibilität anderer Abfragen.

Beim Einsatz von Microsoft® OLE DB Provider for Jet unter Microsoft Jet, Version 4.x, können von Prozeduren aus auf Parameter zugegriffen werden, indem Sie das ANSI-Fragezeichen (?) als Parametermarke verwenden. Wenn Sie die SQL-Syntax verwenden, können Sie das Äquivalent zu einem QueryDef-Objekt erstellen.


Analysieren <Jet-Definition>

Analysieren

Teile einer Anweisung oder eines Ausdrucks kennzeichnen und diese Teile anhand bestimmter Sprachregeln überprüfen.


Teilreplikat <Jet-Definition>

Teilreplikat

Eine Datenbank, die nur eine Untermenge der Datensätze eines vollständigen Replikats enthält. Mit einem Teilreplikat können Sie Filter festlegen und Beziehungen erkennen, die definieren, welche Untermengen der Datensätze aus dem vollständigen Replikat in der vorhandene Datenbank erscheinen sollen.


Pass-Through-Abfrage <Jet-Definition>

Pass-Through-Abfrage

Eine SQL-spezifische Abfrage, die Sie verwenden, um Befehle direkt an einen SQL-Datenbankserver (wie Microsoft® SQL Server™) zu senden. Bei Pass-Through-Abfragen arbeiten Sie mit den Tabellen auf dem Server, anstatt die Tabellen zu verknüpfen. Pass-Through-Abfragen werden verwendet, um SQL-Abfragen und systembezogene Befehle auszuführen, die in SQL-Dialekten geschrieben wurden, die nur der Server richtig interpretieren kann.

Eine Pass-Through-Abfrage kann Datensätze zurückgeben, muß dies jedoch nicht. Wenn Daten zurückgegeben werden, werden sie immer in einem Snapshot zurückgegeben.


Berechtigung <Jet-Definition>

Berechtigung

Ein oder mehrere Attribute, die angeben, wie ein Benutzer auf Daten oder Objekte in einer Datenbank zugreifen kann. Wenn ein Benutzer z. B. Leseberechtigung für eine Tabelle oder Abfrage hat, kann er Daten in der Tabelle oder Abfrage abrufen und anzeigen, aber er kann die Daten nicht verändern.


Beständiges Objekt <Jet-Definition>

Beständiges Objekt

Ein in der Datenbank gespeichertes Objekt, z. B. eine Datenbanktabelle oder ein QueryDef-Objekt. Recordset-Objekte vom Typ Dynaset oder Snapshot sind keine beständigen Objekte, da sie bei Bedarf im Hauptspeicher erstellt werden.


Vollständig <Jet-Definition>

Vollständig

Eine Sperrmethode, bei der die Datenseite, die einen oder mehrere Datensätze (u.a. den momentan bearbeiteten Datensatz) enthält, anderen Benutzern nicht zur Verfügung steht, wenn Sie die Edit-Methode verwenden, und erst wieder verfügbar wird, nachdem Sie die Update-Methode ausgeführt haben. Vollständiges Sperren wird aktiviert, wenn die LockEdits-Eigenschaft des Recordset-Objekts den Wert True hat.


Persönliche ID (PID) <Jet-Definition>

Persönliche ID (PID)

Eine alphanumerische Zeichenfolge, bei der zwischen Groß- und Kleinschreibung unterschieden wird und die 4 - 20 Zeichen lang ist. Das Microsoft® Jet-Datenbankmodul verwendet diese Zeichenfolge in Verbindung mit dem Namen des Kontos, um einen Benutzer oder eine Gruppe in einem Workgroup-Objekt zu identifizieren. Sie geben die PID und den Kontonamen an, wenn Sie einen neuen Benutzer oder eine neue Gruppe einrichten.


Primärschlüssel <Jet-Definition>

Primärschlüssel

Ein oder mehrere Felder, deren Werte jeden Datensatz in einer Tabelle eindeutig kennzeichnen. In einer Beziehung wird ein Primärschlüssel verwendet, um auf bestimmte Datensätze in einer Tabelle, die aus einer anderen Tabelle stammen, zu verweisen. Ein Primärschlüssel wird Fremdschlüssel genannt, wenn darauf aus einer anderen Tabelle verwiesen wird. Es gibt nur einen Primärschlüssel. In einer Tabelle "Personal" können Sie z. B. die Personalausweisnummer als Primärschlüssel verwenden.


Primärtabelle <Jet-Definition>

Primärtabelle

Die 1-Seite in zwei in Beziehung stehenden Tabellen in einer 1:n-Beziehung mit einer Fremdtabelle. In der Regel wird eine Primärschlüsseltabelle verwendet, um die referenzielle Integrität herzustellen.


Priorität <Jet-Definition>

Priorität

Ein Wert vom Typ Long, der die Priorität des Replikats zur Verwendung während der Konfliktauflösung angibt. Ein gültiger Prioritätswert für ein globales Replikat liegt zwischen 0 und 100 einschließlich. Lokale und anonyme Replikate weisen stets die Priorität 0 auf. Tritt während einer Synchronisierung ein Konflikt auf, wird das Replikat mit der höchsten Priorität übernommen. Die nicht übernommenen Daten werden in der Konflikttabelle protokolliert.


Prozedur <Jet-Definition>

Prozedur

Ähnlich einer Ansicht, mit der Ausnahme, dass die SQL-Syntax SELECT-Anweisungen (Abfragen, die Zeilen zurückgeben) zum Übergeben von Parametern und DML-Abfragen (Abfragen, die keine Zeilen zurückgeben) mit den Schlüsselwörtern UPDATE, INSERT, DELETE und SELECT INTO unterstützt. Im Prinzip entspricht sie einem QueryDef-Objekt, mit der Ausnahme, dass sie von der SQL-Syntax aus erstellt werden kann, ohne dabei das DAO-Objektmodell verwenden zu müssen.


Prozedurabfrage <Jet-Definition>

Prozedurabfrage

Eine SQL-Anweisung, die eine gespeicherte Prozedur ausführt.


Eigenschaft <Jet-Definition>

Eigenschaft

Ein mit einem Namen versehenes Attribut eines Objekts. Eigenschaften definieren Objektmerkmale wie Größe, Farbe und Bildschirmposition oder den Zustand eines Objekts (aktiviert oder deaktiviert).


Pseudoindex <Jet-Definition>

Pseudoindex

Ein dynamischer Querverweis auf ein oder mehrere Tabellendatenfelder (Spalten), mit dessen Hilfe eine ODBC-Tabelle (Servertabelle) ohne eindeutigen Index bearbeitet werden kann. Ein Pseudoindex ist nicht der tatsächlich vorhandene Index auf der Servertabelle, sondern ein Querverweis, den das Microsoft® Jet-Datenbankmodul verwenden kann, um Tabellenaktualisierungen zu unterstützen. Ein Pseudoindex ist nur dann erforderlich, wenn eine ODBC-Tabelle nicht über einen eindeutigen Index verfügt, mit dessen Hilfe die Tabelle aktualisiert werden kann. Sie benötigen keinen Pseudoindex, wenn die Tabelle bereits über einen eindeutigen Index verfügt oder wenn die Tabelle nicht aktualisiert werden muss. (Tabellen können nicht über einen eindeutigen Index verfügen, wenn sie für die schreibgeschützte Nutzung vorgesehen waren.) In früheren Versionen wurden Pseudoindizes als Indexspezifikationen bezeichnet.


Abfrage <Jet-Definition>

Abfrage

Eine formalisierte Anweisung an eine Datenbank, entweder eine Gruppe von Datensätzen zurückzugeben oder eine bestimmte Operation auf einer Gruppe von Datensätzen durchzuführen, entsprechend der Angaben in der Abfrage. Die folgende Anweisung für eine SQL-Abfrage gibt beispielsweise Datensätze zurück:

SELECT CompanyName FROM Publishers WHERE Region = 'NY'

Sie können Auswahl-, Aktions-, Kreuztabellen-, Parameter- und SQL-Abfragen erstellen und ausführen.


Schreibgeschützt <Jet-Definition>

Schreibgeschützt

Eine Art des Zugriffs auf Daten, bei der Informationen abgerufen, aber nicht verändert werden können.


Datensatz <Jet-Definition>

Datensatz

Eine Gruppe zusammenhängender Daten zu einer Person, einem Ort, einem Ereignis oder einem anderen Sachverhalt. Tabellendaten werden in Datensätzen (Zeilen) in der Datenbank gespeichert. Jeder Datensatz besteht aus einer Gruppe miteinander in Beziehung stehender Felder (Spalten). Jedes Feld legt dabei ein Informationsattribut für diesen Datensatz fest. Zusammengenommen definiert ein Datensatz eine bestimmte Einheit von Informationen, die aus einer Datenbank abgerufen werden können.

Ein Datensatz wird auch als Zeile bezeichnet.

Siehe auch

Zeile


Referenzielle Integrität <Jet-Definition>

Referenzielle Integrität

Regeln, die Sie angeben, um Beziehungen zwischen Tabellen festzulegen und zu erhalten, wenn Sie Datensätze hinzufügen, ändern oder löschen. Durch das Durchsetzen der Referenziellen Integrität werden Benutzer daran gehindert, Datensätze zu einer verknüpften Tabelle hinzuzufügen, für die es keinen Primärschlüssel gibt, Werte in einer Primärtabelle zu ändern, die Datensätze ohne Zuordnung in einer verknüpften Tabelle zur Folge hätten, und Datensätze aus einer Primärtabelle zu löschen, wenn es zugehörige Datensätze in einer in Beziehung stehenden Tabelle gibt.

Wenn Sie die Option dbRelationDeleteCascade oder dbRelationUpdateCascade für eine Beziehung auswählen, lässt das Microsoft® Jet-Datenbankmodul Änderungen und Löschvorgänge zu, ändert oder löscht aber gleichzeitig in Beziehung stehende Datensätze, um sicherzustellen, dass die Regeln weiterhin eingehalten werden.

Microsoft Jet, Version 4.x, ermöglicht über Microsoft OLE DB Provider for Jet den Zugriff auf eine umfangreichere Gruppe von ANSI SQL-Funktionen sowie auf die referenzielle Aktion der ANSI-NULL-Weitergabe.


Beziehung <Jet-Definition>

Beziehung

Eine Verbindung, die zwischen gemeinsamen Feldern (Spalten) in zwei Tabellen hergestellt wird. Eine Beziehung kann entweder eine 1:1-, eine n:n- oder eine 1:n-Beziehung sein.


Erneut abfragen <Jet-Definition>

Erneut abfragen

Das erneute Ausführen einer Abfrage, um Änderungen an den Datensätzen zu berücksichtigen, neu hinzugefügte Datensätze abzurufen und gelöschte Datensätze zu entfernen.


Reserviertes Wort <Jet-Definition>

Reserviertes Wort

Ein Wort, das Bestandteil der SQL-Sprache des Microsoft® Jet-Datenbankmoduls ist. Reservierte Wörter schließen ein: Namen von Anweisungen, vordefinierten Funktionen und Datentypen, Methoden, Operatoren und Objekte. Beispiele sind SELECT, UPDATE, BETWEEN, SET und INSERT. Verwenden Sie keine reservierten Wörter für Variablen- oder Objektnamen.

Bei der Verwendung von Microsoft OLE DB Provider for Jet wurde die reservierte Wortliste für Microsoft Jet, Version 4.X, erweitert, um kompatibel zu ANSI SQL-92 zu sein.


Rechte Verknüpfung <Jet-Definition>

Rechte Verknüpfung

Eine rechte Verknüpfung umfasst alle Datensätze von der zweiten (rechten) zweier Tabellen, auch wenn es keine entsprechenden Werte für Datensätze in der ersten (linken) Tabelle gibt.

Sie können z. B. LEFT JOIN mit den Tabellen "Abteilungen" (links) und "Personal" (rechts) verwenden, um alle Abteilungen, auch solche, denen keine Angestellten zugeordnet sind, auszuwählen. Um alle Angestellten auszuwählen, auch solche, die keiner Abteilung zugeordnet sind, verwenden Sie RIGHT JOIN.


Rechte Inklusionsverknüpfung <Jet-Definition>

Rechte Inklusionsverknüpfung

Eine Inklusionsverknüpfung, in der alle Datensätze von der rechten Seite der RIGHT JOIN-Operation in der SQL-Anweisung einer Abfrage zum Recordset-Objekt hinzugefügt werden, auch wenn es keine entsprechenden Werte in dem verknüpften Feld der Tabelle auf der linken Seite gibt. Datensätze aus der linken Tabelle werden nur dann mit Datensätzen aus der rechten Tabelle verknüpft, wenn es übereinstimmende Werte in den verknüpften Feldern gibt.


Rollback (Zurücksetzen) <Jet-Definition>

Rollback (Zurücksetzen)

Beim Einsatz von Microsoft® OLE DB Provider for Jet, können Sie nun eine Transaktion starten (BeginTrans), zu Ende führen (CommitTrans) oder zurücksetzen (RollBack), ohne dabei über das Objektmodell DAO oder ADO zu gehen. Mit dem Zurücksetzen (RollBack) kann eine gestartete Transaktion (BeginTrans) beendet oder entfernt werden.


Zeile <Jet-Definition>

Zeile

Eine Reihe zusammenhängender Spalten oder Felder zum Speichern von Daten. Eine Zeile ist synonym zu einem Datensatz im Microsoft® Jet-Datenbankmodul. Eine Tabelle besteht aus keiner, einer oder mehreren Zeilen mit Daten.


Sperren auf Zeilenebene <Jet-Definition>

Sperren auf Zeilenebene

Eine neue Funktion bei Microsoft® Jet, Version 4.x, mit der einem Benutzer ermöglicht wird, eine Zeile und nicht eine ganze Seite zu sperren, wenn eine Zeile aktualisiert oder gelöscht wird. Das Sperren auf Zeilenebene ist für Spalten nicht implementiert, die indiziert sind oder LV (Long-Wert)-Datentypen aufweisen (Memofeld).


Verfolgung auf Zeilenebene <Jet-Definition>

Verfolgung auf Zeilenebene

Bei der Verfolgung auf Zeilenebene handelt es sich um einen Mechanismus, bei dem die vollständige Zeile zur Konfliktbestimmung und -auflösung verwendet wird. Ein Konflikt tritt stets auf, wenn mehrere Replikate dieselbe Zeile auch dann ändern wollen, wenn die geänderten Daten in verschiedenen Spalten dieser Zeile stehen.


Laufzeitfehler <Jet-Definition>

Laufzeitfehler

Ein Fehler, der bei der Ausführung des Codes auftritt. Ein Laufzeitfehler tritt auf, wenn eine Anweisung versucht, eine ungültige Operation auszuführen.


Laufzeit <Jet-Definition>

Laufzeit

Die Zeit, zu der Code ausgeführt wird. Zur Laufzeit können Sie mit dem Code interaktiv wie ein Benutzer arbeiten.


Gültigkeitsbereich <Jet-Definition>

Gültigkeitsbereich

Das Attribut einer Variablen oder Prozedur, das festlegt, in welchen Abschnitten welcher Module die Variable oder Prozedur bekannt ist. Es gibt drei Ebenen von Gültigkeitsbereichen: öffentliche Ebene, Modulebene und Prozedurebene. Auf Variablen, die Sie mit Public deklarieren, kann aus jedem Modul zugegriffen werden, während Variablen, die Sie in einem bestimmten Modul deklarieren, auch nur innerhalb dieses Moduls verwendet werden können. Variablen, die Sie in einer Sub- oder Function-Prozedur deklarieren, können auch nur in der jeweiligen Prozedur verwendet werden.


Geschützte Arbeitsgruppe <Jet-Definition>

Geschützte Arbeitsgruppe

Ein Workgroup-Objekt einer Microsoft® Jet-Datenbank, an das sich Benutzer mit einem Benutzernamen und einem Kennwort anmelden, und in dem der Zugriff auf Datenbankobjekte entsprechend den Berechtigungen, die für Benutzerkonten und Gruppen angegeben sind, beschränkt ist.


Sicherheit <Jet-Definition>

Sicherheit

Sammelbegriff für die Maßnahmen, mit denen die Zugriffsmöglichkeiten angegeben oder eingeschränkt werden, die angegebenen Benutzern oder Benutzergruppen zur Verfügung stehen, um auf Daten und Objekte in einer Datenbank zuzugreifen.


Ausgangswert <Jet-Definition>

Ausgangswert

Optionaler Parameter, der mit den Counter- oder Identity-Datentypen verwendet wird. In SQL DDL nur verfügbar, wenn Microsoft® OLE DB Provider for Jet verwendet wird. Kann auch als der Anfangswert bezeichnet werden. Der Ausgangswert ist der erste von zwei optionalen Parametern für Counter- oder Identity-Datentypen.

Bei der folgenden SQL-Anweisung handelt es sich um ein Beispiel mit Parametern:

CREATE TABLE Kunden (KundId IDENTITY (100, 10)

CONSTRAINT pkKunden PRIMARY KEY, CFrstNm VARCHAR(10),

CLstNm VARCHAR(15));

Die Spalte KundId in der ersten Zeile hat einen Wert von 100. Die zweite Zeile weist einen Wert von 110 auf.

Werden die optionalen Parameter ohne die Werte (1,1) verwendet, setzt Jet den Ausgangswert nicht auf den Maximalwert in der Tabelle zurück. Dieses Verhalten unterscheidet sich zu früheren Versionen von Jet. Werden beim Komprimieren der Datenbank die optionalen Parameter nicht übergeben oder der Wert (1,1) nicht verwendet, wird der Ausgangswert auf den Maximalwert der Counter- oder Identity-Spalte in der Tabelle zurückgesetzt.

Siehe auch

Inkrementwert


Auswahlabfrage <Jet-Definition>

Auswahlabfrage

Eine Abfrage, die eine Frage zu den in bestimmten Tabellen gespeicherten Daten stellt und ein Recordset-Objekt zurückgibt, ohne die Daten zu ändern. Nachdem die Daten des Recordset-Objekts abgerufen sind, können Sie diese untersuchen und Änderungen an den Daten in den zugrundeliegenden Tabellen vornehmen. Im Gegensatz dazu können Aktionsabfragen Änderungen an den Daten vornehmen, aber keine Datensätze zurückgeben.


Reflexivverknüpfung <Jet-Definition>

Reflexivverknüpfung

Eine Verknüpfung, in der Datensätze aus einer Tabelle mit anderen Datensätzen derselben Tabelle kombiniert werden, wenn die miteinander verknüpften Felder dieselben Werte haben. Eine Reflexivverknüpfung kann eine Exklusionsverknüpfung oder eine Inklusionsverknüpfung sein. Eine Reflexivverknüpfung ist hilfreich, wenn Sie Antworten auf hierarchische Abfragen benötigen, etwa eine Abfrage, die alle Vorgesetzten zusammen mit ihren Mitarbeitern ermittelt.


Server <Jet-Definition>

Server

Das Datenbankmanagement-System, das Daten für Client-Anwendungen bereitstellt. Server und Clients sind häufig in einem Netzwerk miteinander verbunden. Ein Datenbankserver enthält und verwaltet in der Regel eine zentrale Quelle von Daten, die von Client-Anwendungen im Netzwerk abgerufen und verändert werden können.


Server Cursor <Jet-Definition>

Server-Cursor

Cursor-Schlüsselgruppen, die nicht auf der Client-Arbeitsstation erstellt werden, sondern auf dem Server. Während Client-Cursor den Cursor der Arbeitsstation kopieren, nutzt der Server-Cursor die Ressourcen der Datenbank zur Wartung des Cursors.


Sitzung <Jet-Definition>

Sitzung

Eine Sitzung umfasst eine Folge von Operationen, die das Microsoft® Jet-Datenbankmodul durchführt. Eine Sitzung beginnt, wenn sich ein Benutzer anmeldet, und endet, wenn sich ein Benutzer abmeldet. Alle Operationen, die während einer Sitzung durchgeführt werden, bilden einen Transaktionsbereich und unterliegen den Berechtigungen, die durch den Anmeldenamen des Benutzers und das Kennwort festgelegt sind. Sitzungen werden von DAO als Workspace-Objekte implementiert.


Short (Datentyp) <Jet-Definition>

Short (Datentyp)

Ein grundlegender Datentyp des Microsoft® Jet-Datenbankmoduls, der dem Datentyp Integer in Visual Basic® für Applikationen entspricht. Eine Variable vom Typ Short wird als Wert mit 16 Bits (2 Bytes) gespeichert und kann Werte im Bereich von -32.768 bis 32.767 aufnehmen.


Single (Datentyp) <Jet-Definition>

Single (Datentyp)

Ein grundlegender Datentyp, der Fließkommawerte einfacher Genauigkeit nach IEEE-Format speichert. Eine Variable vom Typ Single wird als Wert mit 32 Bits (4 Bytes) gespeichert und kann einen Wert von -3,402823E38 bis -1,401298E-45 (negativ), von 1,401298E-45 bis 3,402823E38 (positiv) sowie den Wert 0 annehmen.


Snapshot <Jet-Definition>

Snapshot

Eine feste Kopie einer Gruppe von Datensätzen, die aus einer Datenbank abgerufen und in den Hauptspeicher kopiert werden. Ein Snapshot, der von einer Datenquelle, die mit Microsoft® Jet verbunden ist, stammt, kann nicht aktualisiert werden. Recordset-Objekte vom Typ Snapshot können von einer Basistabelle, einer Abfrage oder einem anderen Recordset-Objekt erstellt werden. Alle SQL-Pass-Through-Abfragen geben Snapshots zurück.


Sortierreihenfolge <Jet-Definition>

Sortierreihenfolge

Ein sequentielles Verfahren, um Daten alphabetisch oder numerisch zu sortieren. Die Sortierreihenfolge kann entweder aufsteigend oder absteigend sein.


SQL-spezifische Abfrage <Jet-Definition>

SQL-spezifische Abfrage

Eine Abfrage, die nur durch Schreiben einer SQL-Anweisung erstellt werden kann. Unterabfragen und Pass-Through-, Union- sowie Datendefinitionsabfragen sind SQL-spezifische Abfragen.


SQL-Anweisung/Zeichenfolge <Jet-Definition>

SQL-Anweisung/Zeichenfolge

Ein Ausdruck, der einen SQL-Befehl definiert (SQL = Structured Query Language = Strukturierte Abfragesprache), z. B. SELECT, UPDATE oder DELETE, und Klauseln wie WHERE und ORDER BY enthalten kann. SQL-Zeichenfolgen und -Anweisungen werden in der Regel in Abfragen, Recordset-Objekten und Aggregatfunktionen verwendet, können aber auch verwendet werden, um eine Datenbankstruktur zu erstellen oder zu verändern.


Standardabweichung <Jet-Definition>

Standardabweichung

Ein Parameter, der anzeigt, wie eine Wahrscheinlichkeitsfunktion um ihren Mittelwert verteilt ist, und der den Wert der Quadratwurzel der Varianz (Betrag der Abweichung) um den Mittelwert hat. Wird zur Beschreibung von Wertemengen verwendet, um festzustellen, wie stark der Wert vom arithmetischen Mittelwert abweicht.


Standard-Namenskonventionen <Jet-Definition>

Standard-Namenskonventionen

Eine Reihe bestimmter Regeln zur Benennung von DAO-Objekten. Namen können bis zu 64 Zeichen lang sein und eine beliebige Kombination aus Buchstaben, Zahlen, Leerzeichen und Sonderzeichen enthalten, wobei die Zeichen Punkt (.), Ausrufezeichen (!), ein umgekehrtes schräges einfaches Anführungszeichen (`) und eckige Klammern ([ ]) ausgeschlossen sind. Außerdem können Sie keine führenden Leerzeichen oder Steuerzeichen (ASCII-Werte 0 bis 31) verwenden.


Statischer Cursor <Jet-Definition>

Statischer Cursor

Eine Ergebnisgruppe, in der die Mitgliedschaft, die Reihenfolge und die Werte grundsätzlich festgelegt sind, wenn der Cursor geöffnet wird. Wenn andere Benutzer Zeilen aktualisieren, löschen oder einfügen, zeigt der Cursor dies erst dann an, wenn er geschlossen und erneut geöffnet wird.


Zeichenfolgenvergleich <Jet-Definition>

Zeichenfolgenvergleich

Durch einen Operator feststellen, ob eine Zeichenfolge größer oder gleich einer anderen ist. Wenn Sie Option Compare Text im Deklarationsbereich eines Moduls verwenden, wird beim Zeichenfolgenvergleich die Groß-/Kleinschreibung nicht beachtet. Wenn Sie Option Compare Binary verwenden, wird die Groß-/Kleinschreibung beachtet. Wenn Sie Option Compare Database verwenden, wird die Vergleichsmethode durch die aktuelle Datenbank festgelegt.


String (Datentyp) <Jet-Definition>

String (Datentyp)

Ein grundlegender Datentyp, der Zeichen speichert. Eine Variable vom Typ String hat entweder eine feste oder eine variable Länge und enthält ein Zeichen pro Byte. Zeichenfolgen fester Länge werden mit einer feststehenden Länge deklariert und können 1 bis etwa 64 KB Zeichen (2^16) aufnehmen. Zeichenfolgen variabler Länge können eine beliebige Länge bis maximal 2 Milliarden Zeichen (2^31) (ungefähr 64 KB Zeichen [2^16] für Microsoft® Windows®, Version 3.1 und früher) haben - abzüglich eines kleinen Speicherbereichs zur Speicherverwaltung.


Zeichenfolgenausdruck <Jet-Definition>

Zeichenfolgenausdruck

Jeder Ausdruck, der eine Folge aneinanderhängender Zeichen ergibt. Zulässige Elemente eines Ausdrucks sind Funktionsaufrufe, die eine Zeichenfolge zurückgeben, Zeichenfolgenliterale, Zeichenfolgenkonstanten, Zeichenfolgenvariablen, einer Zeichenfolge vom Typ Variant oder eine Funktion, die eine Zeichenfolge vom Typ Variant (VarType 8) zurückgibt.


SQL (Structured Query Language) <Jet-Definition>

SQL (Structured Query Language)

Eine Sprache, die zum Abfragen, Aktualisieren und Verwalten relationaler Datenbanken verwendet wird. SQL kann verwendet werden, um bestimmte Daten, die aus der Datenbank gelesen werden sollen, abzurufen, zu sortieren und zu filtern.

Die Verwendung von SQL SELECT-Anweisungen ist überall dort zulässig, wo auch ein Tabellenname, Abfragename oder Feldname zulässig ist. Sie können z. B. eine SQL-Anweisung anstelle des Namens einer Tabelle in der OpenRecordset-Methode verwenden.


Unterabfrage <Jet-Definition>

Unterabfrage

Eine Unterabfrage ist eine SELECT-Anweisung, die in einer SELECT, SELECT...INTO, INSERT...INTO, DELETE oder UPDATE-Anweisung oder einer anderen Unterabfrage verschachtelt ist.


Syntaxfehler <Jet-Definition>

Syntaxfehler

Ein Fehler, der auftritt, wenn Sie eine Code-Zeile eingeben, die von Microsoft® Visual Basic® nicht erkannt wird.

Anmerkung Syntaxregeln für die einzelnen Schlüsselwörter werden im Abschnitt Syntax im entsprechenden Hilfethema beschrieben. Sie erhalten die Hilfe zu einem Schlüsselwort in der Entwicklungsumgebung, wenn Sie das Schlüsselwort auswählen und dann F1 drücken.


Systemobjekt <Jet-Definition>

Systemobjekt

Ein Datenbankobjekt, das vom Microsoft® Jet-Datenbankmodul definiert wurde, z. B. die Tabelle "MSysIndexes".


Tabelle <Jet-Definition>

Tabelle

Die Grundeinheit für gespeicherte Daten in einer relationalen Datenbank. Eine Tabelle speichert Daten in Datensätzen (Zeilen) und Feldern (Spalten). Die Daten beschreiben in der Regel eine bestimmte Kategorie von Informationen, z. B. zu Angestellten oder Artikeln. Eine Tabelle wird auch als Basistabelle bezeichnet.

Ein Recordset-Objekt vom Typ Tabelle ist eine logische Darstellung einer Basistabelle in einer Datenbank.


TEMP <Jet-Definition>

TEMP

Die Umgebungsvariable TEMP wird durch die Datei autoexec.bat gesetzt, wenn Ihr System gestartet wird. Im allgemeinen verweist TEMP auf einen Bereich auf der Festplatte, der von Microsoft® Windows® und anderen Programmen (wie dem Microsoft Jet-Datenbankmodul) verwendet wird, um Informationen zu speichern, die nicht gespeichert bleiben müssen, nachdem das System heruntergefahren wurde. Durch die folgende Zeile in der Datei autoexec.bat zeigt die Umgebungsvariable TEMP z. B. auf den Ordner D:\TempArea:

SET TEMP=D:\TempArea


Temporärer Datenträger <Jet-Definition>

Temporärer Datenträger

Der Datenträger oder das Verzeichnis, das durch die Umgebungsvariable TEMP des Betriebssystems gekennzeichnet ist, und in dem das Microsoft® Jet-Datenbankmodul temporäre Dateien und Abfrageergebnisse speichert. Wird auch als temporäres Laufwerk bezeichnet. Die Umgebungsvariable TEMP kann zwar auch auf eine RAM-Disk verweisen, jedoch wird dies nicht empfohlen.


Text (Datentyp, mit Längenangabe) <Jet-Definition>

Text (Datentyp, mit Längenangabe)

Ein Felddatentyp. Textfelder können bis zu 255 Zeichen oder die durch die Size-Eigenschaft des Field-Objekts angegebene Anzahl an Zeichen enthalten, je nachdem, welcher Wert kleiner ist. Wenn die Size-Eigenschaft des Textfelds auf 0 festgelegt ist, kann das Feld Daten bis zu 255 Zeichen enthalten.


Textdatentyp (ohne Längenangabe) <Jet-Definition>

Textdatentyp (ohne Längenangabe)

Ein Felddatentyp. Textfelder, die ohne ausdrückliche Längenangabe definiert werden, entsprechen einem Memo-Feld und können bis zu 2,14 GB Zeichen enthalten.


Time (Datentyp) <Jet-Definition>

Time (Datentyp)

Ein Datentyp, der einen Zeitwert speichert. Der Wert ist abhängig von der Uhreinstellung der Datenquelle.


Transaktion <Jet-Definition>

Transaktion

Eine Folge von Änderungen, die an den Daten und dem Schema einer Datenbank vorgenommen werden. Markieren Sie den Anfang einer Transaktion mit der BeginTrans-Anweisung, übernehmen Sie die während der Transaktion vorgenommenen Änderungen mit der CommitTrans-Anweisung, und machen Sie alle seit BeginTrans vorgenommenen Änderungen mit der Rollback-Anweisung rückgängig.

Transaktionen sind optional und können auf bis zu fünf Ebenen ineinander verschachtelt werden. Transaktionen beschleunigen Operationen, die Daten verändern, und erlauben ein einfaches Rückgängigmachen der vorgenommenen Änderungen.

Transaktionen beziehen sich global auf das angegebene Workspace-Objekt der Datenbank.


Unicode (Darstellungsformat) <Jet-Definition>

Unicode (Darstellungsformat)

Ein 16-Bit-Zeichensatz, der vom Unicode-Konsortium verwaltet wird und sämtliche Zeichen enthält, die zur Darstellung aller Sprachen dieser Erde benötigt werden. Unicode wird verstärkt eingesetzt, um multilinguale Vorgänge mit Software zu vereinfachen.


Union-Abfrage <Jet-Definition>

Union-Abfrage

Eine SQL-spezifische Auswahlabfrage, die ein Recordset-Objekt vom Typ Snapshot erstellt, das Daten aus allen angegebenen Datensätzen in mindestens zwei Tabellen enthält, wobei mehrfach vorkommende Datensätze entfernt werden. Mehrfach vorkommende Datensätze sind im Ergebnis enthalten, wenn Sie das Schlüsselwort ALL hinzufügen.

Beispielsweise liefert eine Union-Abfrage auf den Tabellen "Kunden" und "Lieferanten" ein Recordset-Objekt vom Typ Snapshot, in dem alle Lieferanten aufgeführt sind, die gleichzeitig Kunde sind.


Nicht verwaltetes Replikat <Jet-Definition>

Nicht verwaltetes Replikat

Ein Replikat, das von keinem Synchronizer verwaltet wird. Nicht verwaltete Replikate werden im Synchronisierungsfenster mit einem besonderen Symbol angezeigt. Sie können für nicht verwaltete Replikate keine Synchronisierungszeitpläne festlegen, obwohl sie von anderen Synchronizern oder mit DAO-Code synchronisiert werden können.


Aktualisieren <Jet-Definition>

Aktualisieren

Der Prozess, durch den Änderungen an den Dateien in einem Datensatz gespeichert werden. Bis ein Datensatz gespeichert wird, werden die Änderungen in einem temporären Datensatz gespeichert, dem sogenannten Kopierpuffer. Die UPDATE-Klausel in einer SQL-Anweisung ändert Datenwerte in einem Datensatz oder mehreren Datensätzen (Zeilen) einer Datenbanktabelle.


Aktualisierungsabfrage <Jet-Definition>

Aktualisierungsabfrage

Eine Aktionsabfrage, die eine Gruppe von Datensätzen entsprechend den von Ihnen angegebenen Kriterien ändert. Eine Aktualisierungsabfrage gibt keine Datensätze zurück.


Benutzerkonto <Jet-Definition>

Benutzerkonto

Ein Konto, das durch einen Benutzernamen und eine persönliche ID (PID) gekennzeichnet ist und das erstellt wird, um den Zugriff auf Datenbankobjekte in einem Workgroup-Objekt einer Microsoft® Jet-Datenbank zu verwalten.


Überprüfung <Jet-Definition>

Überprüfung

Die Überprüfung, ob die eingegebenen Daten bestimmte Bedingungen oder Beschränkungen erfüllen.


Überprüfungseigenschaften <Jet-Definition>

Überprüfungseigenschaften

Eigenschaften, die verwendet werden, um Bedingungen für Tabellenfelder und Datensätze festzulegen. Überprüfungseigenschaften umfassen ValidationRule, Required und AllowZeroLength.


Gültigkeitsregel <Jet-Definition>

Gültigkeitsregel

Eine Regel, die Einschränkungen oder Bedingungen für die Eingaben festlegt, die in einem oder mehreren Feldern vorgenommen werden können. Gültigkeitsregeln können für ein Field- oder TableDef-Objekt festgelegt werden. Gültigkeitsregeln werden angewendet, sobald Sie einen Datensatz aktualisieren, der Felder enthält, die überprüft werden müssen. Wenn die Regel nicht eingehalten wird, tritt ein auffangbarer Fehler auf.


VarBinary (Datentyp) <Jet-Definition>

VarBinary (Datentyp)

Ein Datentyp, der binäre Daten variabler Länge speichert. Die maximale Länge beträgt 255 Bytes.


Variable <Jet-Definition>

Variable

Ein benannter Speicherplatz, der Daten enthalten kann, die während der Ausführung des Programms verändert werden. Jede Variable wird durch einen in ihrem Gültigkeitsbereich eindeutigen Namen gekennzeichnet. Ein Datentyp kann, aber muss nicht angegeben werden.

Variablennamen:

  • Müssen mit einem Buchstaben beginnen.
  • Dürfen keine eingebetteten Punkte (.) oder Typenkennzeichen enthalten.
  • Müssen in ihrem Gültigkeitsbereich eindeutig sein.
  • Müssen kürzer als 255 Zeichen sein.


Varianz <Jet-Definition>

Varianz

Das Quadrat der Standardabweichung. Es ist ein Maß für den Betrag, um den alle Werte in einer Gruppe vom Durchschnittswert der Gruppe abweichen.


Variant (Datentyp) <Jet-Definition>

Variant (Datentyp)

Ein besonderer Datentyp, der numerische Werte, Zeichenfolgen- oder Datumswerte sowie die Sonderwerte Empty und Null enthalten kann. Die VarType-Funktion definiert, wie die Daten in einer Variant-Variablen interpretiert werden. Alle Variablen erhalten den Typ Variant, wenn sie nicht explizit mit einem anderen Typ deklariert werden.


Variant-Ausdruck <Jet-Definition>

Variant-Ausdruck

Jeder Ausdruck, der als numerischer Wert, Zeichenfolge oder Datum oder als einer der Sonderwerte Empty und Null ausgewertet werden kann.


Ansicht <Jet-Definition>

Ansicht

Ansicht ist die ANSI-Definition einer virtuellen Tabelle. Eine Ansicht ist ein Synonym für eine gespeicherte Abfrage unter Access, die aus einer SELECT-Anweisung ohne Parameter besteht. Eine Ansicht ist eine gespeicherte Definition, die bei Ausführung realisiert wird. Der Unterschied zu einer Tabelle besteht darin, dass physikalisch keine Daten gespeichert, sondern Daten nur zurückgegeben werden.

Eine Ansicht kann mit der neuen ANSI SQL CREATE VIEW-Syntax erstellt werden, auf die über Microsoft® OLE DB Provider for Jet zugegriffen werden kann. Alternativ kann auch eine Prozedur erstellt werden, die SQL DML-Anweisungen und SELECT-Anweisungen mit Parametern unterstützt. Dies wird mit der neuen CREATE PROCEDURE-Syntax realisiert, auf die über Microsoft OLE DB Provider for Jet zugegriffen werden kann.


Platzhalterzeichen <Jet-Definition>

Platzhalterzeichen

Das Sternchen (*), Prozentzeichen (%), Fragezeichen (?), der Unterstrich (_), das Nummernzeichen (#), Ausrufezeichen (!), der Bindestrich (-) und eckige Klammern ([ ]) sind Platzhalterzeichen. Sie können diese Zeichen in Abfragen und Ausdrücken verwenden, um alle Datensätze, Dateinamen oder anderen Elemente anzugeben, die mit bestimmten Zeichen beginnen oder mit einem bestimmten Muster übereinstimmen. Sie können Platzhalterzeichen und zu suchende Zeichen auch verwenden, um eine Suche weiter einzuschränken, wenn Sie eine SQL-Anweisung verwenden.

Anmerkung Die Platzhalterzeichen Prozentzeichen (%) und Unterstrich (_) werden nur beim Einsatz von Microsoft® OLE DB Provider for Jet verwendet. Auf sie kann nicht über DAO oder die Benutzeroberfläche von Microsoft Access aus zugegriffen werden. Sie werden als Literalwerte bei DAO bzw. der Benutzeroberfläche von Access behandelt.

Symbol | Beispiel | Verwendung
* oder % | wa* findet was, wasser und warum *at findet rat, Salat und Saat | Findet eine beliebige Anzahl an Zeichen und kann überall in der Zeichenfolge verwendet werden.
? oder _ | b?ll findet ball, bell und bill | Findet eine Übereinstimmung mit einem beliebigen Zeichen.
# | 1#3 findet 103, 113, 123 | Findet eine Übereinstimmung mit einer beliebigen Ziffer.
[ ] | b[ae]ll findet ball und bell, aber nicht bill | Findet eine Übereinstimmung mit einem der Zeichen in den Klammern.
! | b[!ae]ll findet bill und bull, aber nicht bell oder ball | Findet eine Übereinstimmung mit einem der Zeichen, die nicht in der Liste sind.
- | b[a-c]d findet bad, bbd und bcd | Findet eine Übereinstimmung mit einem Zeichen aus einem Bereich.

Anmerkung Eine Übereinstimmung mit den Platzhalterzeichen * (Sternchen), ? (Fragezeichen), # (Nummernzeichen) und [ (öffnende Klammer) selbst kann nur gefunden werden, wenn diese Zeichen in eckige Klammern eingeschlossen werden.


Arbeitsgruppe <Jet-Definition>

Arbeitsgruppe

Eine Gruppe von Benutzern in einer Mehrbenutzerumgebung, die auf Daten und auf dieselbe Arbeitsgruppeninformationsdatei (normalerweise die Datei System.mdw) gemeinsam zugreifen.


Arbeitsgruppenadministrator <Jet-Definition>

Arbeitsgruppenadministrator

Ein Mitglied der Gruppe "Admins" in einem Workgroup-Objekt einer Microsoft® Jet-Datenbank. Ein Arbeitsgruppenadministrator kann immer alle Berechtigungen für ein beliebiges in der Workgroup erstelltes Datenbankobjekt erhalten.


Null-Zeichenfolge <Jet-Definition>

Null-Zeichenfolge

Eine Zeichenfolge, die keine Zeichen ("") enthält. Die Len-Funktion einer Zeichenfolge der Länge Null gibt den Wert 0 zurück.


Basis-Computer <Jet-Definition>

Basis-Computer

Ein Computer, der in einer Sterntopologie verwendet wird. Ein Replikat wird von einem Hub Server kopiert und auf dem Basis-Computer abgelegt. Mit dem Replikat können weitere Replikate für andere Computer erstellt werden.

Siehe auch
Hub Server Sterntopologie


Konflikttabelle <Jet-Definition>

Konflikttabelle

Eine Tabelle, die erzeugt wird, wenn zwischen zwei Replikaten ein Synchronisierungskonflikt auftritt. Die Konflikttabelle wird nur für das Replikat angelegt, dessen geänderter Datensatz beim Konfliktlösungsprozess nicht akzeptiert wurde.


Datenbankreplikation <Jet-Definition>

Datenbankreplikation

Der Vorgang, bei dem eine Datenbank reproduziert wird. Dabei können eine oder mehrere Kopien (Replikate) erzeugt werden, die jederzeit synchronisiert werden können. Änderungen an den Daten in einer replizierten Tabelle in einem Replikat werden an die anderen Replikate der Replikatgruppe gesendet und durchgeführt. Änderungen an der Datenbankstruktur im Entwurfs-Master-Replikat (Design Master) werden an alle Replikate der Replikatgruppe gesendet und an diesen durchgeführt.


Standardpartner <Jet-Definition>

Standardpartner

Ein Synchronizer, der zum automatischen Synchronisieren eines Replikats mit anderen Replikaten der Replikatgruppe verwendet wird. Wenn ein Replikat erstellt wird, wird der Synchronizer, der das Quellreplikat verwaltet, der Standardpartner für das neue Replikat.


Standardzeitplan <Jet-Definition>

Standardzeitplan

Eine Vorlage, mit der der Synchronizer den Zeitplan für ein neu verwaltetes Replikat und dessen Synchronisierungspartner festlegt, wenn das neu verwaltete Replikat keinen Standardzeitplan hat. Sobald er festgelegt wurde, können Sie daran Änderungen vornehmen.


Entwurfs-Master (Design Master) <Jet-Definition>

Entwurfs-Master (Design Master)

Eine Datenbank, in anderen Anwendungen auch einfach Design Master genannt, zu der Systemtabellen, Systemfelder und Replikationseigenschaften hinzugefügt wurden. Ein Entwurfs-Master-Replikat (Design Master-Replikat) ist das erste Mitglied einer Replikatgruppe. Änderungen an der Datenbankstruktur können nur mit dem Entwurfs-Master-Replikat (Design Master-Replikat) vorgenommen werden. Alle Replikate einer Replikatgruppe können abwechselnd als Entwurfs-Master-Replikat (Design Master-Replikat) festgelegt werden. Es darf in jeder Replikatgruppe jedoch immer nur ein Entwurfs-Master-Replikat (Design Master-Replikat) existieren.


Ablageordner <Jet-Definition>

Ablageordner

Ein Ort im Netzwerk mit gemeinsamen Zugriff, an dem der Synchronizer Entwurfs- und Datenänderungen ablegen oder abholen kann.


Globale, eindeutige Kennung (GUID) <Jet-Definition>

Globale, eindeutige Kennung (GUID)

Ein 16 Byte großes Feld zum Definieren einer eindeutigen Replikationskennung. GUIDs dienen zum Identifizieren von Replikaten, Replikatgruppen, Tabellen, Datensätzen und anderen Objekten.

Anmerkung In Microsoft® Access werden GUIDs auch als Replikations-IDs bezeichnet.


Hubserver <Jet-Definition>

Hubserver

Ein Computer, der in einer Sterntopologie verwendet wird. Ein Replikat auf diesem Computer kann als Synchronisierungspartner für weitere Replikate verwendet werden.

Siehe auch
Basis-Computer | Sterntopologie
Satelliten-Computer |


Lokales Objekt <Jet-Definition>

Lokales Objekt

Eine Tabelle, die in dem Replikat verbleibt, in dem sie erstellt wurde. Weder das Objekt, noch Änderungen am Objekt werden in andere Elemente der Replikatgruppe kopiert.


Verwaltete Replikate <Jet-Definition>

Verwaltete Replikate

Ein Replikat mit einem zugeordneten Synchronizer. Der Synchronizer sendet Änderungen an andere Replikate in der Gruppe und empfängt sie von ihnen.

Anmerkung Wenn Sie einem Replikat keinen Synchronizer zuweisen, können Sie es immer noch mit dem Code Ihrer Anwendung oder einem anderen Synchronizer synchronisieren. Sie können jedoch keine Terminpläne zur Synchronisierung von diesem Replikat festlegen, wenn Sie ihm keinen Synchronizer zuweisen.


Objektreplikation <Jet-Definition>

Objektreplikation

Der Vorgang, bei dem ein Objekt (Tabelle oder Abfrage) reproduziert wird. Dabei entstehen zwei oder mehr Kopien eines Objekts, die synchronisiert werden. Änderungen am Entwurf des Objekts werden im Entwurfs-Master-Replikat (Design Master-Replikat) ausgeführt und an alle anderen Replikate der Gruppe gesendet und in diesen übernommen.


Synchronisierung auf Anfrage <Jet-Definition>

Synchronisierung auf Anfrage

Der Austausch von Daten zwischen zwei Replikaten, der durchgeführt wird, wenn es vom Benutzer ausdrücklich angefordert wird.


Replikat <Jet-Definition>

Replikat

Eine Kopie einer Datenbank, einschließlich der Tabellen, Abfragen, Formulare, Berichte und Module dieser Datenbank. Ein Replikat ist ein Element einer Replikatgruppe und kann mit anderen Mitgliedern der Replikatgruppe synchronisiert werden. Änderungen an den Daten in einer replizierten Tabelle in einem Replikat werden an die anderen Replikate gesendet und dort durchgeführt.

Anmerkung Der Entwurfs-Master (Design Master) ist auch ein Replikat.


Replizierte Datenbank <Jet-Definition>

Replizierte Datenbank

Eine Datenbank, der zusätzliche Tabellen, Felder und Eigenschaften mit Informationen über Änderungen an Daten und dem Entwurf von replizierten Objekten in der Datenbank hinzugefügt werden.


Repliziertes Objekt <Jet-Definition>

Repliziertes Objekt

Eine Tabelle oder Abfrage, die sich in allen Replikaten der Replikatengruppe befindet. Sie können das replizierte Objekt nur mit dem Entwurfs-Master ändern. Diese Änderungen werden anschließend während einer Synchronisierung an andere Replikate der Replikatgruppe weitergeleitet.


Replikatgruppe <Jet-Definition>

Replikatgruppe

Replikate, die denselben Datenbankentwurf und eine eindeutige Replikatgruppenkennung haben. Elemente einer Replikatgruppe werden synchronisiert.


Replikatgruppenelement <Jet-Definition>

Replikatgruppenelement

Ein Replikat, das einer Replikatgruppe angehört. Elemente einer Replikatgruppe haben denselben Datenbankentwurf und können miteinander synchronisiert werden.


Replizieren <Jet-Definition>

Replizieren

Erzeugen eines Replikats, bzw. einer Kopie eines Objekts, z. B. einer Datenbank.


Replikation <Jet-Definition>

Replikation

Der Vorgang, bei dem an unterschiedlichen Orten Replikate erstellt und synchronisiert werden. Bei der Replikation werden Systemfelder, -tabellen und Eigenschaften zu einer Datenbank hinzugefügt, die ermöglichen, dass Änderungen an den Daten oder am Entwurf einer Datenbank an alle Elemente einer Replikatgruppe gesendet und dort übernommen werden.


Microsoft Replikat-Manager <Jet-Definition>

Microsoft Replikat-Manager

Eine Anwendung, die eine grafische Benutzeroberfläche zur Verfügung stellt, mit der die Position, der Synchronisierungszeitplan und die Beziehung eines oder mehrerer Replikate zu anderen Replikaten einer Replikatgruppe verwaltet werden können. Der Replikat-Manager verwaltet die Einstellungen des Synchronizers, die die Replikation steuern, während der Synchronizer die eigentlichen Synchronisierungsaktivitäten ausführt. Der Replikat-Manager ist Teil von Microsoft® Office 97, Developer Edition.


Sperrfrist <Jet-Definition>

Sperrfrist

Anzahl der Tage, an denen bestimmte Informationen über das Replikat im System verbleiben. Wenn die Sperrfrist abläuft, bevor das Replikat synchronisiert wird, schlägt die Synchronisierung fehl.


Satelliten-Computer <Jet-Definition>

Satelliten-Computer

In einer Sterntopologie ein Computer, auf dem sich ein Replikat befindet. Das Replikat wurde vom Basis-Computer kopiert und wird standardmäßig mit einem Replikat auf dem Hubserver synchronisiert.

Siehe auch
Basis-Computer | Sterntopologie
Hubserver |


Zeitplan <Jet-Definition>

Zeitplan

Der Zeitplan, nach dem der Synchronizer die Synchronisierung mit anderen Replikaten initialisiert. Das kleinste Zeitintervall zwischen zwei geplanten Synchronisierungen beträgt 15 Minuten. Sie können unterschiedliche Zeitpläne für zwei verschiedene Synchronizer festlegen.


Geplante Synchronisierung <Jet-Definition>

Geplante Synchronisierung

Ein Datenaustausch zwischen zwei Replikaten zu einem vorher festgelegten Zeitpunkt.


gemeinsame Netzwerkordner <Jet-Definition>

Gemeinsame Netzwerkordner

Siehe Ablageordner.


Sterntopologie <Jet-Definition>

Sterntopologie

Eine Art Organisationsplan für vernetzte Computer. Bei der Replikation ist damit der Hub Server, Basis-Computer und die Verteilung der Elemente der Replikatgruppe an andere Satelliten-Computer gemeint. Die Topologie ist wichtig, wenn die Synchronisierungszeitpläne festgelegt werden.

Siehe auch
Basis-Computer | Satelliten-Computer
Hubserver |


Synchronisierungskonflikt <Jet-Definition>

Synchronisierungskonflikt

Die Situation, in der die Benutzer zweier Replikate denselben Datensatz geändert haben. Einer der aktualisierten Datensätze wird als "Gewinner" ausgewählt, und der Datensatz im "verlierenden" Replikat wird so aktualisiert, dass er diese Daten enthält. Der andere aktualisierte Datensatz wird in einer Konflikttabelle im verlierenden Replikat gespeichert.


Synchronisierungsfehler <Jet-Definition>

Synchronisierungsfehler

Problem, das während der Synchronisierung auftritt und verhindert, dass Änderungen an einem Datensatz ordnungsgemäß ausgeführt werden können. Synchronisierungsfehler haben eine größere Bedeutung als Konflikte und müssen baldmöglichst gelöst werden.


Synchronisierung <Jet-Definition>

Synchronisierung

Der Vorgang, bei dem zwei Replikate aktualisiert werden und alle aktualisierten Datensätze und Objekte miteinander ausgetauscht werden. Der Austausch der Daten zwischen zwei Replikaten kann in eine oder beide Richtungen verlaufen und von einem Synchronizer verwaltet werden.


Replikatgruppentopologie <Jet-Definition>

Replikatgruppentopologie

Die Reihenfolge, in der Änderungen von Replikat zu Replikat weitergeleitet werden. Die Topologie bestimmt, wie schnell Änderungen in einem anderen Replikat in Ihrem Replikat erscheinen.


Synchronizer (Synchronisierungsmodul) <Jet-Definition>

Synchronizer (Synchronisierungsmodul)

Ein Programm, das Änderungen an einem Replikat überwacht und den tatsächlichen Austausch der Daten zwischen den Replikaten verwaltet. Der Synchronizer arbeitet im Hintergrund und wird in der Task-Leiste angezeigt. Der Synchronizer einer Replikatgruppe befindet sich im Synchronisierungsfenster des Replikat-Managers.

Anmerkung In der vorherigen Version des Replikat-Managers wurde der Synchronizer als Transporter bezeichnet; der Synchronizer wird auch Synchronisierungsmodul genannt.


Synchronisierungsfenster <Jet-Definition>

Synchronisierungsfenster

Der Bereich des Replikat-Managers, in dem die Synchronisierung ausgeführt wird. Sie können die Synchronizer verschieben sowie vergrößern oder verkleinern, damit mehr oder weniger Synchronizer sichtbar sind. Sie können auch auf die Linie zwischen den Modulen klicken, um deren Zeitpläne zu bearbeiten. Um weitere Informationen zu den verschiedenen Symbolen im Synchronisierungsfenster anzuzeigen, klicken Sie im Menü Ansicht auf Legende.