(Untitled)

Hilfe zum Replikationskonflikt-Viewer

Der Replikationskonflikt-Viewer hilft Ihnen beim Anzeigen und Lösen von Konflikten, die während der Mergereplikation aufgetreten sind. Konflikte treten auf, wenn dieselben Daten gleichzeitig an zwei verschiedenen Speicherorten bearbeitet werden, z. B. auf einem Verleger und einem Abonnenten oder aber auf zwei verschiedenen Abonnenten. Die folgenden beiden Konflikte sind möglich:

  • Aktualisierungs- und Einfügekonflikte, bei denen dieselben Daten an zwei verschiedenen Speicherorten geändert werden. Eine Änderung „gewinnt“, während die andere „verliert“.
  • Löschkonflikte, bei denen dieselbe Zeile an einem Speicherort gelöscht und an einem anderen bearbeitet wird.

Diese Konflikte werden auf der Grundlage der Priorität, die beim Erstellen des Abonnements eingestellt war, oder auf der Grundlage benutzererstellter Lösungsprozeduren behoben. Mit dem Replikationskonflikt-Viewer können Sie nachvollziehen, wie diese Konflikte gelöst wurden, und Änderungen an diesen Lösungen vornehmen.

In der folgenden Tabelle sind die im Dialogfeld Microsoft-Replikationskonflikt-Viewer verfügbaren Optionen und deren Funktionen aufgeführt.

Anmerkung

Welche spezifischen Optionen angezeigt werden, hängt vom aufgetretenen Konflikt ab. Nicht alle Optionen sind in allen Dialogfeldern verfügbar. Datumsangaben werden im ISO-Datetime-Format und nicht im lokalen Format angezeigt.

Option | Zweck
Konfliktursache | Anzeige des spezifischen Grundes für den aufgetretenen Konflikt und der Art und Weise, wie dieser gelöst wurde.
Nur Spalten mit Konflikten anzeigen | Anzeige der GUID-Spalte (eindeutiger Bezeichner) und nur der Spalten mit Konflikten.
Alle Spalten anzeigen | Anzeige aller Spalten der Zeile.
Vorhandene Daten beibehalten | Annahme der aktuellen Lösung des Konflikts.
Überarbeitete Daten beibehalten | Annahme der aktuellen Lösung des Konflikts, allerdings unter Berücksichtigung der in den Bearbeitungsfeldern vorgenommenen Überarbeitungen.
Löschung beibehalten | Annahme der aktuellen Lösung des Konflikts; Daten bleiben gelöscht.
Konflikt ignorieren | Kennzeichnung des Konflikts als gelöst, ohne Änderungen vorzunehmen. Dies führt zu einer Diskrepanz und sollte möglichst bald auf andere Weise gelöst werden.
Mit Konfliktdaten überschreiben | Außerkraftsetzung der Lösung des Konflikts und Beibehalten der angezeigten Konfliktdaten.
Mit vorhandenen Daten überschreiben | Außerkraftsetzung der Lösung des Konflikts und Beibehalten der angezeigten vorhandenen Daten.
Mit überarbeiteten Daten überschreiben | Außerkraftsetzung der Lösung des Konflikts durch die Überarbeitungen in den Bearbeitungsfeldern und Beibehalten der angezeigten überarbeiteten Daten.
Daten löschen | Löschen der in den Spalten angezeigten Daten.
Details dieses Konflikts zur späteren Bezugnahme protokollieren | Erstellung einer Kopie des Konflikts und Speicherung in einer eigenen Protokolldatei für die spätere Verwendung. Die Datei wird in Windows-Verzeichnis\profiles\Benutzer\ Anwendungsdaten\Microsoft\Database Replication\UnresolvedConflicts.log gespeichert.


(Untitled)

Hilfe zum Replikationskonflikt-Viewer

Der Replikationskonflikt-Viewer hilft Ihnen beim Anzeigen und Lösen von Konflikten, die während der Mergereplikation aufgetreten sind. Konflikte treten auf, wenn dieselben Daten gleichzeitig an zwei verschiedenen Speicherorten bearbeitet werden, z. B. auf einem Verleger und einem Abonnenten oder aber auf zwei verschiedenen Abonnenten. Konflikte können ebenfalls auftreten, wenn Datenänderungen, die an einem Speicherort vorgenommen wurden, Einschränkungen an einem anderen Speicherort verletzen (dies wird als Divergenzkonflikt bezeichnet). Nach dem Auftreten eines Divergenzkonflikts sind die Daten an den beiden Speicherorten erst nach der Lösung des Konflikts wieder identisch.

Diese Konflikte werden auf der Grundlage der Priorität, die beim Erstellen des Abonnements eingestellt war, oder auf der Grundlage benutzererstellter Lösungsprozeduren behoben. Mit dem Replikationskonflikt-Viewer können Sie nachvollziehen, wie diese Konflikte gelöst wurden, und Änderungen an diesen Lösungen vornehmen.

Wenn Sie einen Divergenzkonflikt ignorieren, sollten Sie den zugrunde liegenden Konflikt zwischen Dateneinschränkungen möglichst bald lösen. Beginnen Sie mit der Protokollierung der Konfliktinformationen, und senden Sie dann den Protokolleintrag an Ihren Systemadministrator. Überprüfen Sie anschließend die Einschränkungen, die für die Daten an den beiden Speicherorten gelten, um sicherzustellen, dass sie an den verschiedenen Standorten identisch sind.

In der folgenden Tabelle sind die im Dialogfeld Microsoft-Replikationskonflikt-Viewer verfügbaren Optionen und deren Funktionen aufgeführt.

Anmerkung

Welche spezifischen Optionen angezeigt werden, hängt vom aufgetretenen Konflikt ab. Nicht alle Optionen sind in allen Dialogfeldern verfügbar. Datumsangaben werden im ISO-Datetime-Format und nicht im lokalen Format angezeigt.

Option | Zweck
Konfliktursache | Anzeige des spezifischen Grundes für den aufgetretenen Konflikt und der Art und Weise, wie dieser gelöst wurde.
Nur Spalten mit Konflikten anzeigen | Anzeige der GUID-Spalte (eindeutiger Bezeichner) und nur der Spalten mit Konflikten.
Alle Spalten anzeigen | Anzeige aller Spalten der Zeile.
Vorhandene Daten beibehalten | Annahme der aktuellen Lösung des Konflikts.
Überarbeitete Daten beibehalten | Annahme der aktuellen Lösung des Konflikts, allerdings unter Berücksichtigung der in den Bearbeitungsfeldern vorgenommenen Überarbeitungen.
Löschung beibehalten | Annahme der aktuellen Lösung des Konflikts; Daten bleiben gelöscht.
Konflikt ignorieren | Kennzeichnung des Konflikts als gelöst, ohne Änderungen vorzunehmen. Dies führt zu einer Diskrepanz und sollte möglichst bald auf andere Weise gelöst werden.
Mit Konfliktdaten überschreiben | Außerkraftsetzung der Lösung des Konflikts und Beibehalten der angezeigten Konfliktdaten.
Mit vorhandenen Daten überschreiben | Außerkraftsetzung der Lösung des Konflikts und Beibehalten der angezeigten vorhandenen Daten.
Mit überarbeiteten Daten überschreiben | Außerkraftsetzung der Lösung des Konflikts durch die Überarbeitungen in den Bearbeitungsfeldern und Beibehalten der angezeigten überarbeiteten Daten.
Daten löschen | Löschen der in den Spalten angezeigten Daten.
Details dieses Konflikts zur späteren Bezugnahme protokollieren | Erstellung einer Kopie des Konflikts und Speicherung in einer eigenen Protokolldatei für die spätere Verwendung. Die Datei wird in Windows-Verzeichnis\profiles\Benutzer\Anwendungsdaten\Microsoft\Database Replication\UnresolvedConflicts.log gespeichert.


(Untitled)

Hilfe zum Replikationskonflikt-Viewer

Der Replikationskonflikt-Viewer hilft Ihnen beim Anzeigen und Lösen von Konflikten, die während der Mergereplikation aufgetreten sind. Konflikte treten auf, wenn dieselben Daten gleichzeitig an zwei verschiedenen Speicherorten geändert werden. Die folgenden beiden Konflikte sind möglich:

  • Aktualisierungs- und Einfügekonflikte, bei denen dieselben Daten an zwei verschiedenen Speicherorten geändert werden. Eine Änderung „gewinnt“, während die andere „verliert“. Bei diesen Konflikten haben Sie die Möglichkeit, die vorhandenen Daten beizubehalten (die Daten, die gewonnen haben) oder die vorhandenen Daten mit den Daten zu überschreiben, die einen Konflikt mit ihnen ausgelöst haben (die Daten, die verloren haben). Wenn Sie die vorhandenen Daten beibehalten, bleiben diese im Replikat, das gewonnen hat, und der Microsoft-Replikationskonflikt-Viewer fügt sie dem Replikat hinzu, dessen Aktualisierung oder Einfügung ursprünglich verloren hat. Wenn Sie die vorhandenen Daten mit den Konfliktdaten überschreiben, werden die Replikate geändert und die Daten hinzugefügt, die ursprünglich verloren haben.
  • Löschkonflikte, bei denen dieselbe Zeile an einem Speicherort gelöscht und an einem anderen bearbeitet wird.

Mit dem Replikationskonflikt-Viewer können Sie nachvollziehen, wie diese Konflikte gelöst wurden, und Änderungen an diesen Lösungen vornehmen.

In der folgenden Tabelle sind die im Dialogfeld Microsoft-Replikationskonflikt-Viewer verfügbaren Optionen und deren Funktionen aufgeführt.

Anmerkung

Welche spezifischen Optionen angezeigt werden, hängt vom aufgetretenen Konflikt ab. Nicht alle Optionen sind in allen Dialogfeldern verfügbar. Datumsangaben werden im ISO-Datetime-Format und nicht im lokalen Format angezeigt.

Option | Zweck
Konfliktursache | Anzeige des spezifischen Grundes für den aufgetretenen Konflikt und der Art und Weise, wie dieser gelöst wurde.
Nur Felder mit Konflikten anzeigen | Anzeige der GUID-Spalte (eindeutiger Bezeichner) und nur der Felder mit Konflikten.
Alle Felder anzeigen | Anzeige aller Felder des Datensatzes.
Vorhandene Daten beibehalten | Annahme der aktuellen Lösung des Konflikts.
Überarbeitete Daten beibehalten | Annahme der aktuellen Lösung des Konflikts, allerdings unter Berücksichtigung der in den Bearbeitungsfeldern vorgenommenen Überarbeitungen.
Löschung beibehalten | Annahme der aktuellen Lösung des Konflikts; Daten bleiben gelöscht.
Konflikt ignorieren | Kennzeichnung des Konflikts als gelöst, ohne Änderungen vorzunehmen. Dies führt zu einer Diskrepanz und sollte möglichst bald auf andere Weise gelöst werden.
Mit Konfliktdaten überschreiben | Außerkraftsetzung der Lösung des Konflikts und Beibehalten der angezeigten Konfliktdaten.
Mit vorhandenen Daten überschreiben | Außerkraftsetzung der Lösung des Konflikts und Beibehalten der angezeigten vorhandenen Daten.
Mit überarbeiteten Daten überschreiben | Außerkraftsetzung der Lösung des Konflikts durch die Überarbeitungen in den Bearbeitungsfeldern und Beibehalten der angezeigten überarbeiteten Daten.
Daten löschen | Löschen der in den Feldern angezeigten Daten.
Details dieses Konflikts zur späteren Bezugnahme protokollieren | Erstellung einer Kopie des Konflikts und Speicherung in einer eigenen Protokolldatei für die spätere Verwendung. Die Datei wird in Windows-Verzeichnis\profiles\Benutzer\Anwendungsdaten\Microsoft\Database Replication\UnresolvedConflicts.log gespeichert.


(Untitled)

Hilfe zum Replikationskonflikt-Viewer

Der Replikationskonflikt-Viewer hilft Ihnen beim Anzeigen und Lösen von Konflikten, die während der Mergereplikation aufgetreten sind. Konflikte treten auf, wenn dieselben Daten gleichzeitig an zwei verschiedenen Speicherorten geändert werden. Konflikte können ebenfalls auftreten, wenn Datenänderungen, die an einem Speicherort vorgenommen wurden, Gültigkeitsregeln an einem anderen Speicherort verletzen (wird als Divergenzkonflikt bezeichnet). Nach dem Auftreten eines Divergenzkonflikts sind die Daten an den beiden Speicherorten erst nach der Lösung des Konflikts wieder identisch.

Diese Konflikte werden auf der Grundlage der Priorität, die beim Erstellen des Replikats eingestellt war, oder auf der Grundlage benutzererstellter Lösungsprozeduren behoben. Mit dem Replikationskonflikt-Viewer können Sie nachvollziehen, wie diese Konflikte gelöst wurden, und Änderungen an diesen Lösungen vornehmen.

Wenn Sie diesen Konflikt ignorieren, sollten Sie ihn möglichst bald auf andere Weise lösen. Beginnen Sie mit der Protokollierung der Konfliktinformationen, und senden Sie dann den Protokolleintrag an Ihren Systemadministrator. Überprüfen Sie anschließend die Einschränkungen, die für die Daten an den beiden Speicherorten gelten, um sicherzustellen, dass sie an den verschiedenen Standorten identisch sind.

In der folgenden Tabelle sind die im Dialogfeld Microsoft-Replikationskonflikt-Viewer verfügbaren Optionen und deren Funktionen aufgeführt.

Anmerkung

Welche spezifischen Optionen angezeigt werden, hängt vom aufgetretenen Konflikt ab. Nicht alle Optionen sind in allen Dialogfeldern verfügbar. Datumsangaben werden im ISO-Datetime-Format und nicht im lokalen Format angezeigt.

Option | Zweck
Konfliktursache | Anzeige des spezifischen Grundes für den aufgetretenen Konflikt und der Art und Weise, wie dieser gelöst wurde.
Nur Felder mit Konflikten anzeigen | Anzeige der GUID-Spalte (eindeutiger Bezeichner) und nur der Felder mit Konflikten.
Alle Felder anzeigen | Anzeige aller Felder des Datensatzes.
Vorhandene Daten beibehalten | Annahme der aktuellen Lösung des Konflikts.
Überarbeitete Daten beibehalten | Annahme der aktuellen Lösung des Konflikts, allerdings unter Berücksichtigung der in den Bearbeitungsfeldern vorgenommenen Überarbeitungen.
Löschung beibehalten | Annahme der aktuellen Lösung des Konflikts; Daten bleiben gelöscht.
Konflikt ignorieren | Kennzeichnung des Konflikts als gelöst, ohne Änderungen vorzunehmen. Dies führt zu einer Diskrepanz und sollte möglichst bald auf andere Weise gelöst werden.
Mit Konfliktdaten überschreiben | Außerkraftsetzung der Lösung des Konflikts und Beibehalten der angezeigten Konfliktdaten.
Mit vorhandenen Daten überschreiben | Außerkraftsetzung der Lösung des Konflikts und Beibehalten der angezeigten vorhandenen Daten.
Mit überarbeiteten Daten überschreiben | Außerkraftsetzung der Lösung des Konflikts durch die Überarbeitungen in den Bearbeitungsfeldern und Beibehalten der angezeigten überarbeiteten Daten.
Daten löschen | Löschen der in den Feldern angezeigten Daten.
Details dieses Konflikts zur späteren Bezugnahme protokollieren | Erstellung einer Kopie des Konflikts und Speicherung in einer eigenen Protokolldatei für die spätere Verwendung. Die Datei wird in Windows-Verzeichnis\profiles\Benutzer\Anwendungsdaten\Microsoft\Database Replication\UnresolvedConflicts.log gespeichert.