Einleitung

Navigation: »Keine übergeordneten Themen verfügbar«

Einleitung

HeavyLoad simuliert eine starke Belastung auf einem PC und erlaubt Ihnen zu überprüfen, ob Workstations und Server PCs auch unter starker Belastung zuverlässig arbeiten.

Außerdem ermöglicht HeavyLoad es, das Verhalten von Systemen unter schwindenden System-Ressourcen (Arbeitsspeicher, freier Speicherplatz) zu testen.


Installation

Navigation: »Keine übergeordneten Themen verfügbar«

Installation

Führen Sie das Installationsprogramm aus und folgen Sie den Anweisungen. HeavyLoad kann über die Systemsteuerung wieder deinstalliert werden. Unterstützt werden alle Windows-Betriebssysteme ab Windows 8.1.

Alternativ können Sie HeavyLoad als portable Version, beispielsweise auf einem USB-Stick, verwenden. Hierzu wählen Sie auf der Download-Seite von HeavyLoad das entsprechende ZIP-Archiv anstelle des Installers aus. Danach entpacken Sie dieses und können das Programm ohne Installation verwenden.


Schnellstart

Navigation: »Keine übergeordneten Themen verfügbar«

Schnellstart

Nach der Installation kann HeavyLoad über das Windows Start-Menü oder der Verknüpfung auf dem Desktop gestartet werden. Im Folgenden erklären wir die wichtigsten Elemente des Hauptfensters:

1.Über diese Schaltfläche wird der Testdurchlauf mit den zuvor gewählten Testmethoden gestartet.

2.Über diese Schaltfläche werden die Tests beendet.

3.Über diesen "Maximum Terror"-Button werden alle Tests mit maximalen Einstellungen gestartet um das System voll auszulasten.

4.Die Gewünschten Test-Methoden lassen sich hier auswählen.

5.In den Optionen können erweiterte Einstellungen wie Grenzwerte, Laufzeit und Anzahl der benutzten Prozessorkerne konfiguriert werden.

6.Hier kann das Aktualisierungsintervall des Diagramms eingestellt werden.

7.Die Statusleiste zeigt Hinweistexte und informiert über relevante Werte während des Tests.


Start-Parameter

Navigation: Schnellstart >

Start-Parameter

HeavyLoad kann mit folgenden Parametern über ein Skript oder die Kommandozeile aufgerufen werden.

/START

Startet den Testdurchlauf mit den angegebenen Test-Methoden.

/CPU <n>

Aktiviert die Test-Methode: Prozessor auslasten.

Durch n kann optional die Anzahl der zu belastenden Prozessorkerne eingestellt werden. Der maximale Wert ist hierbei vom System abhängig.

/MEMORY <n>

Aktiviert die Test-Methode: Arbeitsspeicher reservieren.

Optional kann mit n der frei zu bleibende Arbeitsspeicher in MB angegeben werden.

/FILE <n>

Aktiviert die Test-Methode: Testdatei erzeugen. Optional kann mit n der frei zu bleibende Festplattenplatz angegeben werden.

/TESTFILEPATH <"\path">

Gibt den Pfad an, an welchem die Testdatei gespeichert werden soll. Dieser Parameter kann nur in Verbindung mit dem Parameter /FILE verwendet werden.

/TREESIZE

Aktiviert die Test-Methode: TreeSize ausführen.

/GPU

Aktiviert die Test-Methode: GPU auslasten.

/DURATION <n>

Legt die Laufzeit in n Minuten fest. Wird dieser Parameter nicht gesetzt, läuft der Test dauerhaft. Die Angabe von n ist bei diesem Parameter Pflicht!

/AUTOEXIT

Beendet das Programm nach der unter /DURATION mit n angegebenen Laufzeit automatisch. Dieser Parameter kann nur in Verbindung mit dem /DURATION n Parameter verwendet werden.

/NOGUI

Startet HeavyLoad ohne Benutzeroberfläche im Hintergrund. HeavyLoad startet nur, wenn auch der Parameter /START und mindestens eine Test-Methode mit angegeben wurde. Wird keine maximale Laufzeit festgelegt, läuft HeavyLoad so lange, bis das Programm manuell über den Taskmanager beendet wurde.

Beispiel:

HeavyLoad.exe /CPU 2 /MEMORY 200 /FILE 150 /TESTFILEPATH "C:\Users\exampleuser\AppData\Local\Temp\" /GPU /TREESIZE /DURATION 10 /AUTOEXIT /START


Was ist neu?

Navigation: »Keine übergeordneten Themen verfügbar«

Was ist neu?

Siehe "Was ist neu?" online.


Test Methoden

Navigation: »Keine übergeordneten Themen verfügbar«

Test Methoden

TestCPU

Prozessor auslasten

Dieser Test lastet den Prozessor zu 100% aus. Hierzu wird eine komplexe Berechnung ausgeführt.

TestWriteFile

Testdatei erzeugen

HeavyLoad erzeugt eine Testdatei, die während des Tests kontinuierlich mit Daten beschrieben wird. Die Datenrate, mit der die Testdatei auf die Festplatte geschrieben wird, kann in den Optionen festgelegt werden.

TestMemory

Arbeitsspeicher reservieren

HeavyLoad reserviert kontinuierlich Arbeitsspeicher, was dazu führt, dass dem System weniger Arbeitsspeicher zur Verfügung steht. Die Datenrate, mit der HeavyLoad den Arbeitsspeicher reserviert, kann in den Optionen festgelegt werden.

TestTreeSize

TreeSize ausführen

Dieser Test startet für jede lokale Partition eine Instanz von TreeSize Free. TreeSize Free läuft dabei in einer Endlosschleife, bis der Test beendet wird.

TestGPU

GPU auslasten

HeavyLoad belastet verfügbare Grafikprozessoren. Eine 3D-gerenderte Grafik wird verwendet, um die GPU-Nutzung während des Tests zu erhöhen.


Prozessor auslasten

Navigation: Test Methoden >

Prozessor auslasten

Ziel: Wird dieser Test gestartet, lastet HeavyLoad den Prozessor mit Hilfe einer komplexen Berechnung vollständig aus. Hierdurch lassen sich Zuverlässigkeit, Stabilität sowie das Verhalten des Systems unter einer großen Last analysieren.

Anpassungen: Im Optionendialog CPU lassen sich über die Option "Verwendete logische Prozessoren" die Anzahl der logischen Prozessoren (physische und virtuelle Prozessorkerne), welche von HeavyLoad ausgelastet werden sollen, manuell einstellen. HeavyLoad erkennt automatisch, wie viele logische Prozessoren auf einem System zur Verfügung stehen. Standardmäßig wird die maximale Anzahl an verfügbaren logischen Prozessoren für den Test verwendet und der Prozessor somit vollständig ausgelastet.

Grafische Anzeige: Wie hoch die aktuelle gesamte Prozessorauslastung ist, lässt sich über das angezeigte Liniendiagram ablesen. Hierzu muss in der Legende die Option "Prozessorlast" aktiviert sein. Der Wert wird dabei in Prozent angegeben. Zusätzlich wird der genaue Prozentwert der Auslastung auch in der Statusbar am unteren Fensterrand angezeigt. Der Wert der Auslastung berechnet sich durch alle verfügbaren Kerne und deren momentanen Auslastung. Ein Wert von 100 Prozent wird nur dann erreicht, wenn der Test auf alle Kerne angewendet wird.

Hinweis: Die aktuelle Auslastung wird auch dann berechnet, wenn gerade kein Test aktiv ist. So lassen sich Einflüsse auf die Prozessorlast, z.B. durch andere Programme, auch bei inaktiven Tests schnell identifizieren.


Testdatei erzeugen

Navigation: Test Methoden >

Testdatei erzeugen

Ziel: HeavyLoad erzeugt eine temporäre Testdatei, die kontinuierlich mit Daten beschrieben wird, um so den Festplattenplatz eines Laufwerks zu befüllen. Verwendet wird dieser Test, um zu prüfen, wie sich ein System bei schwindendem Festplattenplatz verhält. Über einen variablen Grenzwert kann hierbei bestimmt werden, wie viel Festplattenplatz frei bleiben soll. Ist dieser Grenzwert erreicht, überschreibt HeavyLoad die Datei solange, bis neuer Festplattenplatz frei geworden ist. Das Laufwerk, dessen Speicher beschrieben werden soll, ergibt sich aus dem Pfad, unter dem die Testdatei angelegt wird. Wird kein Pfad angegeben, schreibt HeavyLoad die Datei in das Standardverzeichnis für Temporärdateien unter "C:\Benutzer\Nutzername\AppData\Local\Temp" und lastet entsprechend den Festplattenplatz von Laufwerk "C:" aus. Nachdem der Test beendet ist, wird diese Datei automatisch gelöscht.

Anpassungen: Der Test lässt sich über den Optionendialog Testdatei individuell anpassen. Neben dem Pfad, unter dem die Testdatei angelegt werden soll, können zusätzlich die Datenrate in MB/s, mit der die Datei beschrieben wird, und auch der frei zu bleibende Festplattenspeicher eingestellt werden. Der tatsächliche maximale Wert ist dabei von dem jeweiligen System abhängig

Grafische Anzeige: Über die Option "Festplattenplatz", in der Legende des Liniendiagrams, kann die Anzeige des verfügbaren Festplattenplatzes des zu testenden Laufwerkes aktiviert werden. Der Wert wird hierbei in Megabyte angegeben. Während der Test-Ausführung wird in der Statusbar die aktuelle Größe der Datei angezeigt.

Hinweis: Da auch andere Programme Festplattenspeicher beanspruchen, kann es vorkommen, dass nachdem HeavyLoad den Grenzwert erreicht hat, der freie Festplattenspeicher unter den eingestellten Grenzwert fällt.


Arbeitsspeicher reservieren

Navigation: Test Methoden >

Arbeitsspeicher reservieren

Ziel: HeavyLoad reserviert kontinuierlich Arbeitsspeicher bis zu einer festgelegten Obergrenze. Hierdurch lässt sich das Verhalten des Systems bei knapp werdenden Arbeitsspeicher nachbilden.

Anpassungen: Über die Option "Verfügbarer Speicher" kann festgelegt werden, wieviel Speicher nicht von HeavyLoad reserviert werden und für das System weiterhin zur Verfügung stehen soll. Außerdem lässt sich die Geschwindigkeit, mit welcher der Speicher alloziert wird, individuell festlegen. Angegeben wird die Geschwindigkeit in MB/s. Der tatsächliche maximale Wert ist dabei von dem jeweiligen System abhängig. Diese Einstellungen finden sich in dem Optionendialog Speicher.

Grafische Anzeige: Wie viel freier Arbeitsspeicher dem System aktuell in Megabyte zur Verfügung steht, kann in dem Liniendiagramm über die Legendenoption "Verfügbarer Arbeitsspeicher" angezeigt werden. Bei laufendem Test wird in der StatusBar zusätzlich ausgegeben, wieviel Arbeitsspeicher aktuell von HeavyLoad reserviert ist und wieviel Arbeitsspeicher dem System noch zur Verfügung steht, inklusive dem StandBy Speicher.

Der StandBy Speicher gibt an, wie viel Speicher das Betriebssystem für aktive Prozesse reserviert hat, aber aktuell nicht nutzt.

Hinweis: Da auch andere Programme Arbeitsspeicher beanspruchen, kann es vorkommen, dass nachdem HeavyLoad den Grenzwert erreicht hat, der freie Arbeitsspeicher unter den eingestellten Wert fällt.


TreeSize ausführen

Navigation: Test Methoden >

TreeSize ausführen

Ziel: HeavyLoad simuliert mit Hilfe der Scanfunktion von TreeSize Free eine hohe Zugriffsrate auf Verzeichnisse und Dateien Ihrer lokalen Festplatten und testet hierdurch die Belastbarkeit der Festplatten. TreeSize Free wird hierzu so lange in einer Endlosschleife mit vordefinierten Startparametern ausgeführt, bis der Test beendet wird.

Tipp: Möchten Sie nicht nur wissen wie belastbar Ihre Festplatte ist, sondern auch wie es um Ihren Festplattenplatz bestellt ist? Unser gratis Tool TreeSize Free liefert Ihnen die Antwort. Mehr Informationen über TreeSize finden Sie auf unserer Webseite unter https://www.jam-software.de/treesize_free.


GPU auslasten

Navigation: Test Methoden >

GPU auslasten

Ziel: Mit diesem Test lassen sich verfügbare Grafikprozessoren auslasten. Hierbei wird eine 3D Grafik gerendert, welche eine hohe Belastung der GPU simuliert.

Anpassungen: In dem Optionendialog GPU lassen sich über die Option "Verwendete GPU(s)" die Grafikprozessoren, welche von HeavyLoad ausgelastet werden sollen, manuell auswählen. HeavyLoad erkennt automatisch im System verbaute dedizierte Grafikkarten sowie intergrierte Grafikeinheiten von Prozessoren. Standardmäßig werden alle GPUs getestet.

Grafische Anzeige: Wie hoch die aktuelle Auslastung der GPU ist, lässt sich über das angezeigte Liniendiagram in FPS (Frames per Second) ablesen. Hierzu muss in der Legende die Option "Bilder pro Sekunde" aktiviert sein.
In der StatusBar wird während des laufenden Tests die genaue FPS-Zahl ausgegeben.

Hinweis: Der GPU-Belastungstest arbeitet nur zuverlässig, wenn aktuelle Treiber für alle zu testenden GPUs installiert sind. Das Ausführen auf virtuellen Maschinen oder über eine Remote-Desktop-Verbindung kann zu einer fehlerhaften Darstellung der 3D-Komponente führen.


Anmerkungen zu den Testmethoden

Navigation: Test Methoden >

Anmerkungen zu den Testmethoden

Der Zweck von HeavyLoad ist es, ein System einer starken Last auszusetzen, um so analysieren zu können, wie sich das System in diesem Zustand verhält und um zu sehen, ob es bei voller Auslastung noch stabil läuft.

HeavyLoad ist kein "Benchmarking"-Tool und wertet nicht aus, wie gut ein System im Vergleich zu ähnlichen Setups ist.

Bitte beachten Sie, dass es bei der, durch die Tests erzeugten, starken Auslastung auch immer zu Systemabstürzen oder Bluescreens kommen kann. Wichtige Daten sollten daher vor dem Starten der Tests immer gesichert werden.

Ein paar Tipps, die dabei helfen können, zu bestimmen, ob ein Test erfolgreich war:

·Ein Test sollte mindestens eine Stunde lang laufen. In der Regel werden keine weiteren Fehler mehr gefunden, wenn ein System bereits seit mehr als 5 Stunden stabil unter einem Test läuft.

·Wenn der Computer keine negativen Symptome zeigt, war der Test erfolgreich.

·Wenn der Test nicht erfolgreich war, kann sich dies durch einen Systemabsturz oder einen Bluescreen ausdrücken.


Optionen

Navigation: »Keine übergeordneten Themen verfügbar«

Optionen

Der Optionen-Dialog kann über das Menü Extras > Optionen... oder über die Schaltfläche [image] geöffnet werden. Er enthält folgende Reiter:

· CPU

· GPU

· Speicher

· Testdatei

· Verschiedenes


CPU Optionen

Navigation: Optionen >

CPU Optionen

Unter dem Reiter "CPU", können "CPU Optionen" und "Thread Optionen" eingestellt werden.

CPU Optionen

Verwendete logische Prozessoren

Wenn das System über einen Prozessor mit mehreren logischen Prozessoren (physische oder virtuelle Kerne) verfügt, kann hier eingestellt werden, wie viele davon für den CPU-Belastungstest verwendet werden sollen.

Thread Optionen

Thread Priorität

Diese Option erlaubt das Festlegen der Thread-Priorität, mit der die einzelnen Tests laufen sollen. Sie kann dazu verwendet werden, die Systembelastung durch HeavyLoad präziser zu steuern. Die Aktivierung der Option "Idle" führt dazu, dass der Prozessor nur genutzt wird, wenn er nicht von anderen Prozessen verwendet wird. Eine höhere Priorität kann dazu führen, dass andere Anwendungen während der Ausführung der Tests verzögert oder gar nicht mehr reagieren.


GPU Optionen

Navigation: Optionen >

GPU Optionen

Unter dem Reiter "GPU" kann eingestellt werden, welche vorhandenen Grafikchips für den Stresstest ausgewählt werden sollen.

Standardmäßig werden alle vorhandenen GPUs getestet. Die Option "Alle verfügbaren GPUs testen" überschreibt die unter "Verwendete GPU(s)" getroffene Auswahl, wenn sie aktiviert ist.


Speicher Optionen

Navigation: Optionen >

Speicher Optionen

Unter dem Reiter "Speicher", können der "Grenzwert" und die "Belastung" eingestellt werden.

Grenzwerte

Freier Speicher

Legt den minimal verbleibenden Arbeitsspeicher fest.

Hinweis: Da auch andere Programme Arbeitsspeicher beanspruchen, kann es vorkommen, dass nachdem HeavyLoad den Grenzwert erreicht hat, der freie Arbeitsspeicher unter den eingestellten Wert fällt.

Belastung

Schreibgeschwindigkeit Arbeitsspeicher

Legt die Geschwindigkeit in MB/s fest, mit der HeavyLoad Arbeitsspeicher reserviert.

Hinweis: Der tatsächliche maximale Wert ist dabei von dem jeweiligen System abhängig.


Test Datei Optionen

Navigation: Optionen >

Test Datei Optionen

Unter dem Reiter "Test Datei" kann der "Grenzwert", die "Belastung" und der "Speicherort der Testdatei" eingestellt werden.

Grenzwerte

Freier Speicher

Legt den minimal zu verbleibenden freien Festplattenspeicherplatz auf der Systempartition fest.

Hinweis: Da auch andere Programme Festplattenspeicher beanspruchen, kann es vorkommen, dass nachdem HeavyLoad den Grenzwert

erreicht hat, der freie Festplattenspeicher unter den eingestellten Wert fällt.

Belastung

Schreibgeschwindigkeit Testdatei

Legt die Geschwindigkeit in MB/s fest, mit der HeavyLoad auf die Festplatte schreibt.

Hinweis: Der tatsächliche maximale Wert ist dabei von dem jeweiligen System abhängig.

Speicherort der Testdatei

Hier kann der Speicherort, an dem die Testdatei temporär abgespeichert wird, festgelegt werden.


Verschiedenes Optionen

Navigation: Optionen >

Verschiedenes Optionen

Unter dem Reiter "Verschiedenes" können die Laufzeit und die Programmeinstellungen geändert werden.

Laufzeit

Dauerhaft

Der Testdurchlauf läuft solange, bis er manuell beendet wird.

Test beenden nach [Wert]

Der Testdurchlauf wird nach der voreingestellten Dauer automatisch beendet.

Automatisch beenden

HeavyLoad wird automatisch beendet, nachdem die angegebene Dauer unter "Test beenden nach" abgelaufen ist.

Programmeinstellungen

Zurücksetzen aller Programmeinstellungen auf ihre Initialwerte.

Kommandozeile

Erzeugen der Kommandozeilenparameter, mit den aktuell verwendeten Einstellungen. Der erzeugte String wird in die Zwischenablage kopiert und kann anschließend mit [STRG+V] in CMD.EXE oder in einem Skript verwendet werden, um HeavyLoad per Kommandozeilenaufruf zu starten.


Hinweise & Anregungen

Navigation: »Keine übergeordneten Themen verfügbar«

Hinweise & Anregungen

·HeavyLoad verwendet unsere Freeware TreeSize Free in einer Endlosschleife, um mehr Festplattenaktivität zu produzieren. Mehr Informationen über TreeSize finden Sie unter https://www.jam-software.de/treesize_free.

·Nach einer längeren Verwendung von HeavyLoad kann es vorkommen, dass der Arbeitsspeicher fragmentiert und die Auslagerungsdatei sehr stark angewachsen ist. Es kann daher ratsam sein, Windows neu zu starten, nachdem die Tests abgeschlossen wurden.

·Wenn HeavyLoad nicht unter normalen Bedingungen geschlossen wurde, z.B. bedingt durch eine instabile Hardwarekomponente oder einen Betriebssystem-Fehler, kann die während des Tests angelegte Test-Datei in Ihrem Temp-Ordner zurückbleiben. Diese muss in dem Fall von Hand gelöscht werden.


Copyright & Contact

Navigation: »Keine übergeordneten Themen verfügbar«

Copyright & Contact

Copyright © 2023 Joachim Marder e.K.

JAM Software GmbH
Am Wissenschaftspark 26
54296 Trier

WWW: | https://www.jam-software.de
Support: | https://customers.jam-software.de/contact.php
E-Mail: | HeavyLoad@jam-software.de
Handelsregister: | HRB: 4920 beim Amtsgericht Wittlich
Umsatzsteuer ID: | DE234825349
Geschäftsführer: | Joachim Marder


Übersetzungen

Navigation: »Keine übergeordneten Themen verfügbar«

Übersetzungen

Gerne würden den Nutzern HeavyLoad in Ihrer jeweiligen Sprache anbieten. Auf diese Weise können unsere Nutzer weltweit HeavyLoad lokalisiert und einfach nutzen. HeavyLoad ist bereits auf Deutsch und Englisch verfügbar. Dank der großartigen Hilfe unserer freiwilligen Übersetzer können wir auch folgende Übersetzungen bereitstellen:

Dänisch: Dank an Erik Marcussen, Svend Heinesen, Thomas Vedel und 3 anonyme Übersetzer

Französisch: Dank an Alexandre Mongin, Simon Martin, Ignace Le Roux, Gaillard S-G, David Dissard und 6 anonyme Übersetzer

Griechisch: Dank an GeoVasi69, Prodromos Makridis und 2 anonyme Übersetzer

Japanisch: Dank an Kyotaro Iijima, Tetsuro Shimazaki und Sriram Iyer

Niederländisch: Dank an Jaap Kramer, Kees Bakker, Linda Bijlsma, Leroux und 4 anonyme Übersetzer

Polnisch: Dank an Franciszek, Your Majesty Bartłomiej Rakowiecki, Bartosz Małolepszy (Grodków), Arkadiusz Kurzawa, Łukasz K. und 8 anonyme Übersetzer

Russisch: Dank an kopejkin, Polina Morgan, Vladimir Skovoroda, Alexander Vorfolomeev, Temtaime, Gennady Morozov und 2 anonyme Übersetzer

Slowakisch: Dank an 5 anonyme Übersetzer

Spanisch: Dank an J. M. Fustero, MS-PC, Fabián C. Rodríguez und 4 anonyme Übersetzer

Tschechisch: Dank an Trasak Jiri, Lukáš Francálek, Azuráč, Fishbone und 3 anonyme Übersetzer

Türkisch: Dank an Oğuzhan Güvercin, Mustafa Tosun, Özgür Dedeoğlu, Metin Yıldıran, Emrecan Ürküt, Pumavun, A.M. Sabuncu, Mert Öz, Mustafa Furkan YILMAZ und 10 anonyme Übersetzer

Ungarisch: Dank an Péter Bálint, Peter Bartfai und 4 anonyme Übersetzer

Vietnamesisch: Dank an Nguyễn Lam, Vu Le, Minh Tuyen Nguyen, Đăng Huy und einen anonymen Übersetzer